lkml.org 
[lkml]   [2001]   [Oct]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [solved] iptables v1.2.3: can't initialize iptables table `filter': Module is wrong version
On Sat, Oct 13, 2001 at 03:52:59PM -0700, Aaron Lehmann wrote:
> On Sat, Oct 13, 2001 at 11:44:14PM +0200, peter k. wrote:
> > did that, now it works! :)
> > seems like it doesnt work if i use the iptables from the mandrake rpm
>
> I'm somewhat upset about this. Rusty, what's up? I have to recompile
> the deb against my kernel configuration for it to not myseriously
> complain.

I'm not absolutely sure about the exact cause of the problem.

It should never break (or have broken) against stock kernels. The problem
is known in the following scenario:

a) distributor adds dropped-table (from netfilter patch-o-matic) to kernel
b) distributor builds iptables against this patched kernel
c) distributor ships this iptables
d) user installs new, plain kernel
e) iptables no longer working because it was built against a patched kernel
f) user has to recompile iptables.

--
Live long and prosper
- Harald Welte / laforge@gnumonks.org http://www.gnumonks.org/
============================================================================
GCS/E/IT d- s-: a-- C+++ UL++++$ P+++ L++++$ E--- W- N++ o? K- w--- O- M-
V-- PS+ PE-- Y+ PGP++ t++ 5-- !X !R tv-- b+++ DI? !D G+ e* h+ r% y+(*)
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:08    [W:0.088 / U:1.904 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site