lkml.org 
[lkml]   [2001]   [Oct]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date


> -----Original Message-----
> From: linux-kernel-owner@vger.kernel.org
> [mailto:linux-kernel-owner@vger.kernel.org]On Behalf Of Matti Aarnio
> Sent: Tuesday, October 02, 2001 1:20 AM
> To: LA Walsh
> Cc: linux-kernel@vger.kernel.org
> Subject: Re: 'dd' local works, but not over net, help as to why?
>
>
> On Tue, Oct 02, 2001 at 12:52:48AM -0700, LA Walsh wrote:
> > I'm sure there's an obvious answer to this, but it is eluding me.
> Probably...
>
> > If I am on my local laptop, I can 'dd' an 8G partition to a
> > removable HD of the same or slightly larger size (slightly large
> > because of geometry differences).
> >
> > If I am on my desktop, "I can 'dd' the same size partition to
> > a slightly larger one -- again, no problem.
> >
> > But if I use:
> >
> > dd if=/dev/hda2 bs=1M|rsh other-system of=/dev/sda2 bs=1M, I
> > get failures of running out of room on target.  I've tried
> > a variety of block size ranging from 1K->64G, but no luck.
>
> You are missing one 'dd' from the other system side, but
> are you also sure that the remote system can support large
> files, and that the dd in there does support large files ?
---
Missing 'dd' typo. It's on the other system I tried copying the 8G
to a slightly large 9G partition -- that worked. On the source system
I can copy 8G to another 8G partition. Just running them over rsh seems to
be a problem. Same version of 'dd' on each side (SuSE 7.2).

Maybe I can fool ftp with symlinks tomorrow into doing the copy and see
if that works. Just for fun I tried 'cat' as well -- same error -- out of
space on target.

It transfers a lot of data -- right around 2G the first time I tried it, so
it looked awfully suspicious.

Linda

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:03    [W:0.051 / U:3.544 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site