lkml.org 
[lkml]   [2001]   [Oct]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.4.11-ac3 -- unresolved symbols in cramfs.o --
On Tue, 2 Oct 2001, Alan Cox wrote:

> > This problem is still present in 2.4.11-ac3.
> >
> > > Frank Davis <fdavis@si.rr.com> wrote:
> > >
> > > Hello all,
> > > I received the following while 'make modules_install'
> > > depmod: *** Unresolved symbols in
> > > /lib/modules/2.4.9-ac17/kernel/fs/cramfs/cramfs/cramfs.o
> > > depmod: zlib_fs_inflateInit_
> > > depmod: zlib_fs_inflateEnd
>
> In what circumstances do you get this . I do cross chekx the -ac trees
> for module symbol problems so Im curious what config is triggering it.
>
> Right now I can only trigger a couple of acpi module ones

I get something similar without module support just doing a "make bzImage"
of 2.4.10-ac3.

This is on the laptop that I'm just now setting up so I don't have gpm on
it yet, but let me see what I can get, compiling...

Looks like zconf.h included from zlib_fs.h can't be found. zconf.h
defines voidpf so all hell breaks loose when zconf.h desides to use it.

At least that is what I'm seeing here.

-Chris
--
Two penguins were walking on an iceberg. The first penguin said to the
second, "you look like you are wearing a tuxedo." The second penguin
said, "I might be..." --David Lynch, Twin Peaks

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:17    [W:0.030 / U:0.912 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site