lkml.org 
[lkml]   [2001]   [Oct]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.4.12 cannot find root device on raid


On Thu, 18 Oct 2001, Norbert Preining wrote:

> Hi!
>
> I have the following problem:
>
> kernel 2.4.12, md and raid1 compiled into the kernel.
> /dev/hdb old linux installation
> /dev/md0 -> /dev/hde1,/dev/hdg1 new installation
>
> When I boot my old installation the md device is automatically configured
> by the kernel and I can mount it (reiserfs) without any problems.
>
> When I try to boot the new installation with the same kernel the md device
> is initialized, but the kernel cannot mount the root device. I get msgs
> about FAT problems and about mounting root as msdos.
>
> Here some config files:
> lilo.conf:
> image = /boot/lx-2.4.12
> root = /dev/hdb1
> label = old
> image = /boot/lx-2.4.12
> root = /dev/md0
> label = new
> optional

To use a md as root, you need to add a kernel command line:

md0=1,/dev/hde1,/dev/hdg1

Put that in the append= line of lilo.conf or type it at the lilo command
prompt.

See also Documentation/md.txt in the Linux source tree.

-jwb

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:08    [W:0.070 / U:0.076 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site