lkml.org 
[lkml]   [2001]   [Oct]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectWake-up from APM suspend state by /dev/rtc ?
Date
Hello people,

I wanted to record my favourite Simpsons series from TV via my ATI TV wonder
card. It works fine automatically, no X needed, just framebuffer
(nuppelvideo 0.4, nuv2divx, v4lctl from xawtv). I wanted to have my machine
suspended when waiting for the recording to spare some trees.

There is setting in a bios for turning on interrupts which should cause
wake-up. I turned interrupt 8 on. I modified code from
linux/Documentation/rtc.txt To set alarm to some time. Then I tried 'apm -S'
or 'apm -s' and waited.
Unfortunately it doesn't work. When I wake it up by mouse later, the
modified code from rtc.txt gets the interrupt and finishes fine. But it
doesn't wake up itself by RTC interrupt :(

I also tried to turn on kernel compile flag which enables interrupts when
calling APM bios but it didn't help.

I suppose it's a bios bug, so probably I can't do anything with it.

Anyone tried this successfully? Should it work? Can using ACPI instead of
APM help me with this?

I've got Soyo 6VBA133 motherboard (Slot1) with VIA Apollo 133 chipset,
Celeron 900. Kernel 2.4.12.

Thanks for any helpful reply.

Frantisek


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:08    [W:0.040 / U:17.720 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site