lkml.org 
[lkml]   [2001]   [Oct]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: unkillable process in R state?
James Sutherland wrote:
>
> On Thu, 11 Oct 2001, Ralf Baechle wrote:
>
> > On Thu, Oct 11, 2001 at 12:48:22PM -0400, Christopher Friesen wrote:
> >
> > > I have a process (an instance of a find command) that seems to be
> > > unkillable (ie kill -9 <pid> as root doesn't work).
> > >
> > > Top shows it's status as R.
> > >
> > > Is there anything I can do to kill the thing? It's taking up all unused cpu
> > > cycles (currently at 97.4%).
> >
> > I assume that's kapm-idled. That's normal, it's job is exactly burning
> > unused cycles.
>
> No. He said it's an instance of find.
>
> Stuck in R, though - some sort of loop? Christopher, can you attach gdb to
> it and see what's happening?


Okay, I just tried this, and the pertinant results were:

$ gdb find
GNU gdb 4.18
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show warranty" for details.
This GDB was configured as "ppc-yellowdog-linux"...(no debugging symbols
found)...
(gdb) attach 31075
Attaching to program: /usr/bin/find, Pid 31075



At this point it hangs and ctrl-C has no effect and I have to kill it from
another console.

Attaching to another program worked fine.

Any other ideas?

Chris

--
Chris Friesen | MailStop: 043/33/F10
Nortel Networks | work: (613) 765-0557
3500 Carling Avenue | fax: (613) 765-2986
Nepean, ON K2H 8E9 Canada | email: cfriesen@nortelnetworks.com
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:08    [W:0.063 / U:9.136 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site