lkml.org 
[lkml]   [2001]   [Oct]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: eepro100.c bug on 10Mbit half duplex (kernels 2.4.5 / 2.4.10 / 2.4.11pre6 / 2.4.11 / 2.4.10ac11)
Hi

I haven't noticed this problem on my system...

I have an 82558 that uses this driver on a Tyan S1836DLUAN motherboard.
I have Dual PIIIs and the system is multi homed. I have a 2nd interface that
uses the NE2000 PCI driver.

The system is my workstation but also acts as an internet gateway (via cable
modem) and firewall for 2 other computers. My workstation is on 24/7 and has
never hungup.

I am currently using 2.4.10 for the kernel but I've used most kenels since
the 2.4.0testX days.

In your tests, is the 80 - 130 megs a single file or is it an aggregate. In
my use I far exceed the amount of data but it's web surfing so the files are
much smaller the what you mention.

John

Robbert Kouprie wrote:

> Hi all,
>
> I can confirm that the known bug in the Intel EtherExpress Pro/100
> adapter is still not worked around in recent kernels. The bug only
> manifests itself when the card is operating on 10 Mbit half duplex. On
> 100 Mbit there are no problems. The problem is that after the device
> received certain amount of traffic (between 80 and 130 Mb in my tests)
> the device will lockup on new connections. Processes start to hang after
> this and logging in is impossible. The only solution is to reset the
> interface (using a previously logged in root session) and reboot the
> system.
>

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:08    [W:0.058 / U:11.100 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site