lkml.org 
[lkml]   [2001]   [Oct]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject2.4.10-acX VM troubles
At first I thought that the VM in 2.4.10-acX (I've tried ac3 and ac7) was
a big improvement over vanilla 2.4.9 (my previous kernel). But after
playing around with different versions and patches, and actually running
the same kernel for a day or more I ran into severe problems.

The problem can be triggered by a number of things, ususally involving
semi-heavy disk activitity (kernel recompile, apt-get installs...). It
seems to only happen after the system has been up for a while (10+
hours).

Suddenly the CPU usage jumps to 100%, and the load avarage to 10 or
more. The system becomes completely unresponsive, even the mouse pointer
freezes for long periods of time. It looks like most of the CPU time is
spent in kswapd, and some in kupdated. The harddisk LED shows almost no
activity.

I haven't verified (yet) that this is -acX only, but vanilla 2.4.9 did not
have this problem.

System is a Duron on KT133 chipset, 256M RAM, 300M swap, reiserfs.

/cyr

-----------------------------------------------------------------------
Cat: Come on bud, you're not doing anything I wouldn't do.
Rimmer: What? You'd sacrifice your life for the sake of the crew?
Cat: No, I'd sacrifice *your* life for the sake of the crew.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:08    [W:0.070 / U:1.540 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site