lkml.org 
[lkml]   [2001]   [Jan]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject2.2.18 and EMU10K1 problems...
(please cc me if you reply - thanks :)

I probably missed a message or note or something about this, but when I went
from 2.2.17 to 2.2.18, my sound card (SB Live!) stopped working. It seems
that in 2.2.18, it gets detected TWICE:

--------------------------------
kernel: Linux version 2.2.18
[...]
kernel: Creative EMU10K1 PCI Audio Driver, version 0.7, 20:05:23 Jan 7 2001
kernel: emu10k1: EMU10K1 rev 5 model 0x21 found, IO at 0xb400-0xb41f, IRQ 10
[... IDE, floppy, SCSI, eth0, partition check ...]
kernel: Creative EMU10K1 PCI Audio Driver, version 0.7, 20:05:23 Jan 7 2001
--------------------------------

This is what it normally does:

--------------------------------
kernel: Linux version 2.2.17
[...]
kernel: Creative EMU10K1 PCI Audio Driver, version 0.6, 20:25:53 Jan 7 2001
kernel: emu10k1: EMU10K1 rev 5 model 0x21 found, IO at 0xb400-0xb41f, IRQ 10
[...]
--------------------------------

In the 2.2.18 case, /proc/interrupts doesn't show anything on int 10.

I guess I should (and will) take this up with the EMU10k people, but I was
just wondering if anyone here has seen this problem before? I'm curious how
a broken driver would have made it into .18 like that ;-) ...unless I'm the
one that is broken :)

Thanks,

-Taner
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:52    [W:0.031 / U:3.524 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site