lkml.org 
[lkml]   [2001]   [Jan]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: 2.4.0 Module compile error
Date
On Fri, 05 Jan 2001 11:23:29 -0600, 
George R. Kasica <georgek@netwrx1.com> wrote:
>>make[1]: Nothing to be done for `modules_install'.
>>make[1]: Leaving directory `/usr/src/linux-2.4.0/arch/i386/lib'
>>cd /lib/modules/2.4.0; \
>>mkdir -p pcmcia; \
>>find kernel -path '*/pcmcia/*' -name '*.o' | xargs -i -r ln -sf ../{}
>>pcmcia
>>if [ -r System.map ]; then /sbin/depmod -ae -F System.map 2.4.0; fi
>>depmod: /lib/modules//2.2.18/modules.dep is not an ELF file
>>depmod: error reading ELF header

You have a broken modules.conf that tells depmod to scan _all_ of
/lib/modules or you have an old version of modules or you have some
weird symlinks in /lib/modules. It looks like you have some dangling
symlinks, although I cannot be certain about that.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:52    [W:0.074 / U:0.228 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site