[lkml]   [2001]   [Jan]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: problem with dd for floppy under 2.4.0
    On Mon, 22 Jan 2001 23:23:36 -0600 (CST), Thomas Molina wrote:

    >[1.] One line summary of the problem: seek= parameter for dd under 2.4.0
    >gives permission denied error
    >[2.] Full description of the problem/report:I was creating a new
    >root+boot disk for 2.4.0 this evening. I issued the command:
    >dd if=/tmp/rootfs.gz of=/dev/fd0 bs=1k seek=335
    >and got the error message:
    >dd: /dev/fd0: Permission denied

    There's a known bug in dd where it incorrectly attempts to truncate
    the output file even though it's a block device. In kernels older
    than 2.4.0-test10 or so it got away with this, but now the kernel
    correctly returns an error.

    Use the 'conv=notrunc' option to dd to fix this, i.e.

    dd if=rootfs.gz of=/dev/fd0 bs=1k conv=notrunc seek=XXX

    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 13:18    [W:0.038 / U:26.968 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site