lkml.org 
[lkml]   [2001]   [Jan]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subjectstripping symbols from modules
Date
Hi All,

Is there any way to strip symbols from modules .o files ?
for example, fat.o has many symbols and when you run `file' command
on fat.o - it says that is is not a stripped file.
I tried running `strip' command on fat.o and then tried to
run insmod on the stripped fat.o and then tried to run
insmod on vfat.o. But the insmod on vfat.o generated the
"Unable to handle kernel NULL pointer dereference at virtual address
00000000" message. If there any way to remove symbols and still
load the module successfully and make it work ? Or the
problem is with the strip command ? Should I be using
something else instead of strip to remove symbols from
the module .o ?

I think, I am missing something. But I am not sure.

Thanks and regards,
-hiren
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:18    [W:0.059 / U:1.132 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site