lkml.org 
[lkml]   [2001]   [Jan]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: Via apollo KX133 ide bug in 2.4.x
From
On Fri, Jan 19, 2001 at 07:33:21PM -0500, safemode wrote:
> I'm sorry I can't be more descriptive than that, but there aren't any
> errors ever displayed. What happened was after about a day of uptime, I
> began seeing IO errors when trying to access files. I realized that the
> IO errors occurred on any file I had created. I rebooted since the
> computer became impossible to use and fsck removed everything that I had
> created since upgrading to the release kernel. This is all on ext2fs.
> I tried making bootdisks but they all showed up as being bad. I tried
> copying files to another ext2fs but upon fsck, they too were all removed
> due to corruption. These ext2fs' were not created by the release
> kernel. I had to go back to 2.4.0-test11 before the kernel would write
> to the fs correctly. For the record, I disabled DMA in the kernel and
> i'm compiling for athlon using gcc 2.95.3. I saw the same thing happen
> though when I booted for a kernel compiled for Pentium 2. Since
> reverting back to 2.4.0-test11, however, no FS corruption has been
> observed. Anyone have any idea what this is about? i'm compiling with
> the same options between kernels but 2.4.x (release and newer) do not
> seem to be able to write to the ext2fs correctly. Could this be because
> it was formatted by a 2.2.x kernel? Anyone using this chipset I would
> caution to have backups ready when using it with 2.4.x, as I lost
> hundreds of files to it. Also, no errors were reported anywhere, IO
> errors when trying to stat dirs just started appearing after a couple
> days uptime ...then they would occur whenever you wrote to the FS. Even
> after a reboot. If you need any extra iinfo about kernel options and
> computer config, just ask.
>

I think I'm suffering the same thing on my new Asus A7V. Yesterday I got a
single "error in bitmap, remounting read only" type error, and today I got
some files in /tmp that returned I/O error when stat()ed. I do have DMA
enabled, but only UDMA33. I've done several kernel compiles with no
problems at all so looks like something is on the edge. Think I might go
back to 2.2.x for a bit and see what happens, or maybe just remove the VIA
driver :-((.

P.

I've attached lspci -vxxx output, and kernel config, in case anyone is
investigating.

/dev/hda is Seagate ST330621A.

----------VIA BusMastering IDE Configuration----------------
Driver Version: 2.1e
South Bridge: VIA vt82c686a rev 0x22
Command register: 0x7
Latency timer: 32
PCI clock: 33MHz
Master Read Cycle IRDY: 0ws
Master Write Cycle IRDY: 0ws
FIFO Output Data 1/2 Clock Advance: off
BM IDE Status Register Read Retry: on
Max DRDY Pulse Width: No limit
-----------------------Primary IDE-------Secondary IDE------
Read DMA FIFO flush: on on
End Sect. FIFO flush: on on
Prefetch Buffer: on on
Post Write Buffer: on on
FIFO size: 8 8
Threshold Prim.: 1/2 1/2
Bytes Per Sector: 512 512
Both channels togth: yes yes
-------------------drive0----drive1----drive2----drive3-----
BMDMA enabled: yes no no no
Transfer Mode: UDMA DMA/PIO DMA/PIO DMA/PIO
Address Setup: 30ns 120ns 30ns 120ns
Active Pulse: 90ns 330ns 90ns 330ns
Recovery Time: 30ns 270ns 30ns 270ns
Cycle Time: 60ns 600ns 120ns 600ns
Transfer Rate: 33.0MB/s 3.3MB/s 16.5MB/s 3.3MB/s
[unhandled content-type:application/octet-stream]
\
 
 \ /
  Last update: 2005-03-22 12:57    [W:0.143 / U:0.348 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site