lkml.org 
[lkml]   [2001]   [Jan]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectUSB Mass Storage in 2.4.0
I know there has been some talk arround this topic on this list so If I 
missed the answer I apologize, i just joined the list today. I read
through the archive and all I could find relative to mass storage is the
scsi dependancy, which I am aware of. Here is my situation.

I have a Fujufilm FX-1400 digital camera that uses the USB Mass Storage
driver. I know it works because I had it working in 2.4.0-test12, and in
2.4.0 however I had a major system failure and lost my new kernel. This
time arround I can not get USB Mass Storage to work. I have tried
various combinations of the scsi and usb options. I thought maybe I
needed SCSI Disk support as well but it didnt seem to matter. I have
tried with scsi and usb mass storage as modules and as part of the
kernel, still no luck. Here is what happens when I connect the camera :

Jan 10 18:49:05 t20 kernel: hub.c: USB new device connect on bus1/1,
assigned device number 3
Jan 10 18:49:05 t20 kernel: Product: USB Mass Storage
Jan 10 18:49:05 t20 kernel: SerialNumber: Y-170^^^^^000810X0000003005237
Jan 10 18:49:06 t20 kernel: scsi0 : SCSI emulation for USB Mass Storage
devices
Jan 10 18:49:06 t20 kernel: Vendor: `.À ÀòÏ Model: \206 Ø\177.À¡#
À ÝòÏ Rev: ÿÿÿÿ
Jan 10 18:49:06 t20 kernel: Type: Scanner
ANSI SCSI revision: 02

Now this used to detect a scsi disk and all I had to do was mount it. I
am sure there must be other conflicting config options but I just dont
know what it could be. Any help would be greatly appreciated.

Robert.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:28    [W:0.068 / U:0.648 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site