lkml.org 
[lkml]   [2001]   [Jan]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject2.4.1-pre1 breaks XFree 4.0.2 and "w"

Hi all,

As I just found out, Linux 2.4.1-pre1 breaks several things on
my system that worked perfectly in 2.4.0-final and the entire
2.4.0-ac tree.

XFree 4.2.0 now fails to detect monitor timings and therefore
removes all modelines and bails out. The relevant diff of the
X logfile follows. Note the "nan" bits.

< (II) NV(0): Gamma: 1.80
---
> (II) NV(0): Gamma: nan
385,386c385,386
< (II) NV(0): redX: 0.625 redY: 0.340 greenX: 0.285 greenY: 0.600
< (II) NV(0): blueX: 0.150 blueY: 0.065 whiteX: 0.283 whiteY: 0.298
---
> (II) NV(0): redX: 0.625 redY: nan greenX: 0.285 greenY: 0.600
> (II) NV(0): blueX: 0.150 blueY: nan whiteX: 0.283 whiteY: 0.298
424c424
< (II) NV(0): Clock range: 12.00 to 350.00 MHz
---
> (II) NV(0): Clock range: nan to nan MHz


Moreover, with 2.4.1-pre1 the "w" command behaves in mysterious ways:

Normal output is something like:

USER TTY FROM LOGIN@ IDLE JCPU PCPU WHAT
root tty1 - 2:23pm 4:41 0.03s 0.03s -bash

With 2.4.1-pre1 things look like:

USER TTY FROM LOGIN@ IDLE JCPU PCPU WHAT
root tty1 - 2:21pm ? 0.2147483648s 0.01s w

I'm not sure I need it so precise :-)

Since the 2.4.1-pre1 patch is rather small, it shouldn't be too hard
to hunt down the part that causes these oddities.

Regards,
Udo.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:28    [W:0.087 / U:5.504 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site