lkml.org 
[lkml]   [2001]   [Jan]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
Subject2.2.18: writing an R/O floppy
Hi,

I don't know if it's possible to make fd a read-only device if the
inserted media is write-protected, but I had a strange problem:

I had inserted a write protected floppy and accessed it via autofs as
vfat in 2.2.18. It worked. Some time later it had expired (and I'm not
sure whether I had changed floppies in the meantime).

When I tried an "mdel a:*", it did terminate without message, but a
later "mdir a:" showed all the files there. The kernel had
unsuccessfully tried to write to the floppy however.

It's a bit hard to reproduce that, but I could guess that the disc-
change ore write-protect status was not updated in some case.

Maybe it rings some bell for one of you; if not, never mind.

Regards,
Ulrich

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:28    [W:0.030 / U:1.384 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site