lkml.org 
[lkml]   [2001]   [Jan]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
Subject[PATCH] 2.4.0 agpgart with i815 and external card.

My problem was that I didn't pay enough attention to the configuration
options. I opted for *both* the 440LX/BX/GX, 815, 840, 850 support
(CONFIG_AGP_INTEL) *and* I810/I815 (on-board) support (CONFIG_AGP_I810).

The latter was taking precedence over the former, and getting confused.

Petr Vandrovec has made the very good point that, to stop others from
getting as confused as me, agpgart should default to generic intel if it
can't find the onboard i815 video card.

It's a very small patch (one line really) which I present for your
consideration.

Thanks to Alan Cox and Petr for putting me right.

Charlie - Queens' College - Cavendish Astrophysics - 07866 636318
--- drivers/char/agp/agpgart_be_original.c Wed Jan 10 16:59:35 2001
+++ drivers/char/agp/agpgart_be.c Wed Jan 10 17:00:54 2001
@@ -2373,9 +2373,9 @@
if (i810_dev == NULL) {
printk(KERN_ERR PFX "agpgart: Detected an "
"Intel i815, but could not find the"
- " secondary device.\n");
- agp_bridge.type = NOT_SUPPORTED;
- return -ENODEV;
+ " secondary device. Assuming a "
+ "non-integrated video card.\n");
+ break;
}
printk(KERN_INFO PFX "agpgart: Detected an Intel i815 "
"Chipset.\n");
\
 
 \ /
  Last update: 2005-03-22 13:28    [W:0.039 / U:0.612 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site