lkml.org 
[lkml]   [2000]   [Sep]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: Linux-2.4.0-test8
Date
From
> If anybody wants to explicitly state that their code will be valid under
> any version of the GPL (current or future - whatever they may look like),
> please send patches to say so for the code in question. If you've used the
> FSF boiler-place copyright notice, you already have this in place (it says
> "v2 or later" - the FSF itself doesn't recommend v1 any more).

Every line of code I wrote is under the GPLv2 or later (except those bits
I contributed that were BSD non advertising derived and which I left the BSD
license on).

> (Me, I'm taking the careful "wait and see" approach. I don't know if a GPL
> v3 is imminent, and I don't know if the issues discussed will even
> _become_ real issues, so you might as well consider me a paranoid, if
> careful, bastard).

I think an appropriate concern. The future GPL is constrained by the GPLv2
clause 9 to be 'similar in spirit...'. You also dont ever have to take any
code that specifies GPLv3 or later.

Alan


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:38    [W:0.037 / U:0.148 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site