lkml.org 
[lkml]   [2000]   [Sep]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Quick memory corruption with cramfs
Hi!

> > Is anyone using cramfs?
>
> We use cramfs everyday at http://handhelds.org with Linux
> 2.4.0-test6-rmk1-np2-hh1. We have no problems.

I use test4-pre3 from linux-vr tree.

> > I copy cramfs image from nfs onto /dev/ram0, then mount it. It mounts,
> > and first few accesses are okay, but then it breaks. ls shows garbage
> > etc.
>
> We run the cramfs image out of flash instead of ram. Are you mounting the
> cramfs image as 'ro'??

I used not to. Now I mounted it ro, and, well, it did not help. ls -al
/mnt/bin followed by ls -al /mnt/etc; and I end up with garbage.

I mount cramfs by

mount -tcramfs -n -o ro /dev/ram0 /mnt

after listing of /mnt/bin, md5sum of [relevant part of] /dev/ram0
changes. What is also strange is that ls -al reports error 'file not
found' on on dangling symlinks. (But this is ls from busybox, so it
maybe well its fault.)
Pavel
--
I'm pavel@ucw.cz. "In my country we have almost anarchy and I don't care."
Panos Katsaloulis describing me w.r.t. patents at discuss@linmodems.org
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:38    [W:0.029 / U:1.748 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site