lkml.org 
[lkml]   [2000]   [Sep]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Snoozy Ethernet Interfaces in 2.4testX?
> I have seen unpleasant incidents in which the Ethernet interfaces have
> stopped responding to anything higher-level than a ping after about 20
> days of use. I saw 2 of these on 2.4test1 using an EtherExpress100, and
> one with 2.4test6 using the tulip driver with a PNIC card. Both were
> uniprocessor kernels on uniprocessor hardware (one a PIII and one a
> K6). In 2 of the 3 cases the machine was restored to full function just
> by bringing the Ethernet interface down and back up again; in the 3rd case
> this was not tried.

I have similar complaint against PNIC chip. If for some reason I
disconnect cable and reconnet the link won't be restored unless I ifconfig
interface down and up. It is kind of also hard to figure out what's
current speed of the interface (say it sets full duplex, but it does not
say if it is 10 or 100).

Still I kept it for myself since I did not have time so far to figure out
where I can find latest drivers for tulip for 2.2.x and 2.4.x kernels.
MAINTAINER's file does not list web site and the drivers for beckers
are usually for stable kernels, not bleeding edge like 2.4.x.

Linux Tulip driver version 0.9.9 (August 11, 2000)
eth0: Lite-On 82c168 PNIC rev 32 at 0xc800, 00:A0:CC:62:2B:2A, IRQ 16.
eth0: MII transceiver #1 config 3000 status 7829 advertising 01e1.


--
Adam
http://www.eax.com The Supreme Headquarters of the 32 bit registers


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:38    [W:0.020 / U:12.576 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site