lkml.org 
[lkml]   [2000]   [Sep]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectEEPRO Problems in 2.2.17 (sorry!)

Well,
I thought the problems with the eepro driver from 2.2.16 were fixed in
2.2.17. Apparently the problems really weren't fixed - it did seem to get
more stable though.

I was copying some large over a NFS mount and when it got to about 6 megs,
the NFS mount hung with symptoms similar to the 2.2.16 problems I had.
Which was: no errors in the messages log, a hung NFS mount and reloading
the driver module clears the problem up.

So I started doing some tests with ping to see how long it would stay up.
During those tests, I noticed some wierd DUP packets:

64 bytes from 1.2.3.4: icmp_seq=28 ttl=255 time=0.4 ms
64 bytes from 1.2.3.4: icmp_seq=18 ttl=255 time=10894.5 ms (DUP!)
64 bytes from 1.2.3.4: icmp_seq=29 ttl=255 time=0.4 ms

They were all between 10-20 behind the icmp_seq and had at least a 6000ms
time.

In the middle of a 40meg nfs copy, the driver hung at least 4 times - but
at fairly random intervals. Sometimes it will run for a long time -
sometimes it locks up twice in a row fairly fast.

With the 2.2.14 and previous drivers I did not once notice an error with
this card. The only msg/error I see in the messages log is this:
eth1: set Rx mode to 1 address.

But I've got that message for years now with the eepro driver.

If anyone familiar with this driver wishes to work with me in an attempt
to reproduce this problem, I'd be happy to help.

Thanks,
Brian Hayward

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:41    [W:0.026 / U:0.444 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site