lkml.org 
[lkml]   [2000]   [Sep]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
Subject2.4.0-test7 SB awe32 oddity
From
I have an older Creative Sound Blaster awe32 soundcard, which has worked
fine under many different kernels in the past. It is one of the older
models with jumpers, before the ISAPnP models became available. In the
past, I always set the io, irq, and dma in the menuconfig setup.
However, I haven't been able to get it to work since that option was
taken out of menuconfig/xconfig. I also haven't been able to get it to work
by loading the module by hand, passing it the correct io, irq, and dma
values on the command line.

With test7, things got odder. If I
insmod uart401
insmod sb_lib
insmod sb io=0x220 irq=5 dma=1
I get a "No such device" error. However, if I cat /proc/interrupts,
the Soundblaster shows up as using irq 5. If I subsequently unload
the sb_lib module and try to cat /proc/interrupts, I get this:

Unable to handle kernel paging request at virtual address c983f474
printing eip:
c021cb0a
*pde = 012c5063
*pte = 00000000
Oops: 0000
CPU: 1
EIP: 0010:[<c021cb0a>]
EFLAGS: 00010297
eax: c893f474 ebx: c473411c ecx: c983f474 edx: fffffffe
esi: c40adf28 edi: ffffffff ebp: c983f474 esp: c40adee8
ds: 0018 es: 0018 ss: 0018
Process cat (pid: 253, stackpage=c40ad000)
Stack: c473411a c02efbe4 c4507480 00000002 c02efbe4 c4507480 ffffffff 00000000
c021ccc8 c473411a c0226837 c40adf24 c010b91d c473411a c0226834 c983f474
c473410b c022682e c022b864 00000000 00000c00 c4734000 00001000 000000a0
Call Trace: [<c021ccc8>] [<c0226837>] [<c010b91d>] [<c0226834>] [<c983f474>] [<c022682e>] [<c0226b864>]
[<c01494e1>] [<c014730a>] [<c012f156>] [<c010a64f>]
Code: 80 38 00 74 07 40 4a 83 fa ff 75 f4 29 c8 89 44 24 10 8b 44
Segmentation fault

If I play with the modules more, I can usually make it so I can cat
/proc/interrupts again, but irq 5 shows up as used but sometimes instead of
showing as used by soundblaster, it has a blank where it would normally give
the device name.

The one thing that I suspect might be related to this is that I have had
some problems with odd APIC stuff on this motherboard (Abit bp6 with 2
celeron 533's). However, my soundcard does work in this machine using
kernel 2.2.16.

I'm not currently subscribed to lkml, but I'm curious to know if
other people have seen similar problems with the older sb/awe32 cards. Also,
why was the option to set the card up in the menuconfig/xconfig taken out?
Something to do with the driver re-organization?

I'm running modutils 2.3.14, kernel was compiled with gcc 2.95.2, the rest
is a fairly up-to-date debian woody system. If anyone else has seen this,
or solved this problem, I'd love to hear from them. Thanks.

--
.michael lea \_\_ "baaaaaa"
mazeone@dcaa.net \_\_
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:38    [W:0.038 / U:2.828 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site