lkml.org 
[lkml]   [2000]   [Sep]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectUDMA on SiS5513/5591 changed from 2.2.x to 2.4.x?
I am experiencing problems with UDMA on my system on 2.4 kernels.  It's an
ASUS socket-7 MB, over 2 years old. Below follows a boot log on
2.4.0-test7:

ide: Assuming 33MHz system bus speed for PIO modes; override with
idebus=xx
SIS5513: IDE controller on PCI bus 00 dev 01
SIS5513: chipset revision 208
SIS5513: not 100% native mode: will probe irqs later
SiS5591
ide0: BM-DMA at 0x4000-0x4007, BIOS settings: hda:pio, hdb:pio
ide1: BM-DMA at 0x4008-0x400f, BIOS settings: hdc:pio, hdd:pio
hda: FUJITSU MPE3102AT, ATA DISK drive
hdb: WDC AC14300R, ATA DISK drive
hdc: QUANTUM FIREBALL EL7.6A, ATA DISK drive
hdd: Hewlett-Packard CD-Writer Plus 8100, ATAPI CDROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: 20016348 sectors (10248 MB) w/512KiB Cache, CHS=1245/255/63, UDMA(33)
hdb: 8421840 sectors (4312 MB) w/512KiB Cache, CHS=524/255/63, UDMA(33)
hdc: 15032115 sectors (7696 MB) w/418KiB Cache, CHS=15907/15/63, UDMA(33)
Partition check:
/dev/ide/host0/bus0/target0/lun0: p1
/dev/ide/host0/bus0/target1/lun0: p1 p2 < p5 >
/dev/ide/host0/bus1/target0/lun0:hdc: timeout waiting for DMA
ide_dmaproc: chipset supported ide_dma_timeout func only: 14
hdc: irq timeout: status=0x58 { DriveReady SeekComplete DataRequest }
hdc: timeout waiting for DMA
ide_dmaproc: chipset supported ide_dma_timeout func only: 14
hdc: irq timeout: status=0x58 { DriveReady SeekComplete DataRequest }
spurious 8259A interrupt: IRQ7.
hdc: timeout waiting for DMA
ide_dmaproc: chipset supported ide_dma_timeout func only: 14
hdc: irq timeout: status=0x58 { DriveReady SeekComplete DataRequest }
hdc: timeout waiting for DMA
ide_dmaproc: chipset supported ide_dma_timeout func only: 14
hdc: irq timeout: status=0x58 { DriveReady SeekComplete DataRequest }
hdc: DMA disabled
hdd: DMA disabled
ide1: reset: success
[PTBL] [935/255/63] p1 p2

On 2.2.17pre20 (and back to 2.2.16 at least) everything works fine --
there are no "timeout waiting for DMA" problems. However, the third (and
probably fourth as well -- haven't tested it as the CD-ROM is permanently
there) IDE device (hdc) doesn't detect the geometry correctly. If I swap
any of the drives, the same happens - hdc always detects the partitions
with "[PTBL] <geom>" prepended, with <geom> differing from the "real"
geometry as detected when on ide0.

The "spurious 8259A interrupt: IRQ7" line only started appearing after I
(recently) added a NCR53c810 SCSI controller for playing with...

I have found that having a device on hdc does influence this, as
disconnecting it enables me to switch on UDMA in the BIOS (I'm currently
running it disabled). If I have it enabled in the BIOS on boot, I get
"timeout waiting for DMA" on hda and hdb as well. Could this be a
limitation of the chipset straining on four devices?

I'd appreciate any info...
Regards,
Dewet



-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:38    [W:0.024 / U:4.848 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site