lkml.org 
[lkml]   [2000]   [Sep]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjecttest9-pre7 oops

I tried to add a new mail filter in pine, but when pressing 'x'
(eXtrahdr) in "AllText pattern" field, it dies segfaulting. On the next
try it oopsed. The box went all dead (no sysrq, no ping). All disks IDE,
ext2. /home is NFS mounted from 2.2.15 machine. This happened on console,
while X wasn't running. While X is running it locks up on average once per
day (but I can't determine whether it is the new kernel or the new XFree).
I tried to reproduce this, but only managed to crash pine over and over
again. test7 and test4 have worked flawlessly for many days, test4 was up
for maybe 1 month without a glitch.

Technical info: 2xPII-233, 288M memory, 500M swap, ALSA modules compiled,
but not necessarily loaded and definetely not used. fbcon with
matroxfb compiled in and in use. uptime was on the order of 20-30
hours. Very light load. OOPS message copied from screen to paper and back,
so there _may_ be typos.

More info available on request.


ksymoops 2.3.4 on i686 2.4.0-test9. Options used
-V (default)
-k /proc/ksyms (default)
-l /proc/modules (default)
-o /lib/modules/2.4.0-test9/ (default)
-m /boot/System.map-2.4.0t9p7-1 (specified)

Warning (compare_maps): snd symbol pm_register not found in /lib/modules/2.4.0-test9/misc/snd.o. Ignoring /lib/modules/2.4.0-test9/misc/snd.o entry
Warning (compare_maps): snd symbol pm_send not found in /lib/modules/2.4.0-test9/misc/snd.o. Ignoring /lib/modules/2.4.0-test9/misc/snd.o entry
Warning (compare_maps): snd symbol pm_unregister not found in /lib/modules/2.4.0-test9/misc/snd.o. Ignoring /lib/modules/2.4.0-test9/misc/snd.o entry
invalid operand: 0000
CPU: 1
EIP: 0010:[<c013412a>]
Using defaults from ksymoops -t elf32-i386 -a i386
EFLAGS: 00010082
eax: 0000001c ebx: cf2b6180 ecx: 00000020 edx: 00000001
esi: c15e8900 edi: 00000002 ebp: 00000001 esp: d1fe5eb4
ds: 0018 es: 0018 ss: 0018
Stack: c025c643 c025c97a 000002da c01770d1 cf2b6180 00000001 c15e8900 00000046
c14ead80 c034fbc0 c01a828a c15e8900 00000001 c034f7e4 00000000 c15e8900
c034f700 c01ae4c4 00000001 c14ead80 c034f700 c14ead80 00000286 c01a9b37
Call Trace: [<c025c645>] [<c025c97a>] [<c01770d1>] [<c01a828a>] [<c01ae4c4>] [<c01a9b33>]
[<c01ae460>] [<c010c331>] [<c010c516>] [<c0108e00>] [<c0108e00>] [<c010ac64>]
[<c0108e00>] [<c0100018>] [<c0108e2d>] [<c0108e92>] [<c01ee1a7>] [<c018979f>]
Code: 0f 0b 83 c4 0c c3 57 56 53 8b 74 24 10 8b 54 24 14 85 d2 74

>>EIP; c013412a <end_buffer_io_bad+52/58> <=====
Trace; c025c645 <tvecs+377d/18eb8>
Trace; c025c97a <tvecs+3ab2/18eb8>
Trace; c01770d1 <end_that_request_first+61/b8>
Trace; c01a828a <ide_end_request+32/84>
Trace; c01ae4c4 <ide_dma_intr+64/9c>
Trace; c01a9b33 <ide_intr+12f/198>
Trace; c01ae460 <ide_dma_intr+0/9c>
Trace; c010c331 <handle_IRQ_event+4d/78>
Trace; c010c516 <do_IRQ+a6/f4>
Trace; c0108e00 <default_idle+0/34>
Trace; c0108e00 <default_idle+0/34>
Trace; c010ac64 <ret_from_intr+0/20>
Trace; c0108e00 <default_idle+0/34>
Trace; c0100018 <startup_32+18/cc>
Trace; c0108e2d <default_idle+2d/34>
Trace; c0108e92 <cpu_idle+3e/54>
Trace; c01ee1a7 <vgacon_cursor+197/1a0>
Trace; c018979f <poke_blanked_console+57/5c>
Code; c013412a <end_buffer_io_bad+52/58>
00000000 <_EIP>:
Code; c013412a <end_buffer_io_bad+52/58> <=====
0: 0f 0b ud2a <=====
Code; c013412c <end_buffer_io_bad+54/58>
2: 83 c4 0c add $0xc,%esp
Code; c013412f <end_buffer_io_bad+57/58>
5: c3 ret
Code; c0134130 <end_buffer_io_async+0/e4>
6: 57 push %edi
Code; c0134131 <end_buffer_io_async+1/e4>
7: 56 push %esi
Code; c0134132 <end_buffer_io_async+2/e4>
8: 53 push %ebx
Code; c0134133 <end_buffer_io_async+3/e4>
9: 8b 74 24 10 mov 0x10(%esp,1),%esi
Code; c0134137 <end_buffer_io_async+7/e4>
d: 8b 54 24 14 mov 0x14(%esp,1),%edx
Code; c013413b <end_buffer_io_async+b/e4>
11: 85 d2 test %edx,%edx
Code; c013413d <end_buffer_io_async+d/e4>
13: 74 00 je 15 <_EIP+0x15> c013413f <end_buffer_io_async+f/e4>

Aiee, killing interrupt handler
Kernel panic: Attempted to kill the idle task!

3 warnings issued. Results may not be reliable.


Taneli


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:38    [W:0.027 / U:1.584 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site