lkml.org 
[lkml]   [2000]   [Sep]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectModule unresolved symbol on 2.4.0-test8 SMP

I'm getting the following error when trying to load a module under a
2.4.0-test8 SMP kernel:

[root@porsche13 themod-dev]# insmod themod.o
themod.o: unresolved symbol write_lock
themod.o: unresolved symbol read_lock

The module was compiled with the following options (in a
sub-sub-subdirectory of the kernel source):


gcc -Wall -Wstrict-prototypes -fomit-frame-pointer -pipe -march=i686
-fno-strict-aliasing -D__SMP__ -DMODULE -D__KERNEL__ -DLINUX -Dlinux
-DDEBUG -I../../../include -c themod.c

This has me really puzzled. I've checked out the file
include/asm/spinlock.h & gone so far as to introduce a compiler error
into the read_lock() inline function. The compiler reported the error,
so I know that the read_lock() inline function is being seen when I
build the module. However, I continue to get these unresolved symbol
errors when I try to load the module.

The compiler version I am using is:

egcs-1.1.2-30

I also tried gcc-2.7.3.2 and received the same error.

The module loads and works fine under the uniprocessor 2.4.0-test8
kernel.

Any suggestions on what I am screwing up would be greatly appreciated.

- Sam
----------------------------------------
Sam Watters
SGI
watters@sgi.com
(651) 683-5647
----------------------------------------
See What's Possible!
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:39    [W:0.041 / U:31.124 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site