lkml.org 
[lkml]   [2000]   [Sep]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Packet loss with Znyx 4port 10/100
At 05:23 PM 09/25/2000 -0400, Johathan Earle wrote: 

>
> Hi,
>
> I'm running kernel 2.4.0-test9-pre4 on a Dell GX1 (PIII-500) with a Znyx
> 4port 10/100 card (4 tulip 21143 ethernet controllers onboard).  With the
> ports locked at 10mbps full duplex, and traffic (64byte UDP packets) from
our
> generator running through the box, I am seeing a little under 2% packet loss
> in shortterm stats gathering (< 10minutes).  Decreasing the rate to about
> 5mbps seems to reduce the loss to 0.  Running traffic for extended
periods of
> time (1hr or more - I left it running over the weekend) will show a total
> loss of about 3-3.5%.
>
> I've tried the stock tulip driver, as well as employing the modified tulip
> driver to take advantage of hardware flow control.  No change between the
> two.
>
> I originally thought the problem was due to the card assigning 1 or 2
IRQs to
> all of the ports, thus raising the possibility of IRQ sharing problems.  I
> then moved the card to the 1st slot, and it was then able to obtain a unique
> IRQ for each port.  After I disabled the system's built-in ethernet (which
> also claimed an IRQ used by the Znyx card) and restarted the traffic flow, I
> noticed that the loss decreased about 0.2%.
>
> I've also tried replacing the card with no change.


Where are the errors? input, output? have you tried a different model card?
different hub? We've seen problems with certain pc cards and catalyst switches
for example (im pretty sure its the catalysts, but cisco is never to
blame)...somewhere there is an error counter that will help you find it, most
likely.

db
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:38    [W:0.027 / U:1.644 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site