lkml.org 
[lkml]   [2000]   [Sep]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRE: system hang with usb audio driver
Date
> From: Narayan Desai [mailto:desai@mcs.anl.gov]
>
> >>>>> "Randy" == Dunlap, Randy <randy.dunlap@intel.com> writes:
>
> >> Hi, I have been having problems with the usb audio driver on a set
> >> of Philips DSS330. The driver seemed to work properly up until
> >> 2.3.99-6. The driver included with 2.3.99-6 worked correctly when
> >> included with kernels up to 2.4.0test6 or so. The current driver
> >> (2.4.0test7+) will hang my system reliably when I access the audio
> >> device. The kernel detects the device correctly, the system comes
> >> up correctly, I login and the system dies when I start up xmms. Is
> >> there a newer version of the driver than the one in the kernel or
> >> usb cvs tree? thanks.. -nld
>
> Randy> Not that I know of. Which host controller driver are you
> Randy> using? If it's "uhci", please try "usb-uhci" instead.
> I have tried both uhci drivers and get 2 different results.
> If I use uhci, the process trying to access the audio device is killed
> with an oops. If I use usb-uhci, the swapper is killed and the system
> is gone. I am not really sure how to intrepret this.
> -nld

Right. I've reproduced this with usb-uhci on 2.4.0-test7 (fails)
and test5 (works) and 2.2.18pre9 (works). I'm slowly looking for
the reason/problem (along with other things).

I have added this to the USB 2.4 TODO list as CRITICAL.

Please let me know if you make any progress on this and I will
do the same.

Thanks,
~Randy

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:45    [W:0.022 / U:1.400 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site