lkml.org 
[lkml]   [2000]   [Sep]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectPacket loss with Znyx 4port 10/100
Date
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
<HTML>
<HEAD>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">
<META NAME="Generator" CONTENT="MS Exchange Server version 5.5.2652.35">
<TITLE>Packet loss with Znyx 4port 10/100</TITLE>
</HEAD>
<BODY>

<P><FONT SIZE=2>Hi,</FONT>
</P>

<P><FONT SIZE=2>I'm running kernel 2.4.0-test9-pre4 on a Dell GX1 (PIII-500) with a Znyx 4port 10/100 card (4 tulip 21143 ethernet controllers onboard).&nbsp; With the ports locked at 10mbps full duplex, and traffic (64byte UDP packets) from our generator running through the box, I am seeing a little under 2% packet loss in shortterm stats gathering (&lt; 10minutes).&nbsp; Decreasing the rate to about 5mbps seems to reduce the loss to 0.&nbsp; Running traffic for extended periods of time (1hr or more - I left it running over the weekend) will show a total loss of about 3-3.5%.</FONT></P>

<P><FONT SIZE=2>I've tried the stock tulip driver, as well as employing the modified tulip driver to take advantage of hardware flow control.&nbsp; No change between the two.</FONT></P>

<P><FONT SIZE=2>I originally thought the problem was due to the card assigning 1 or 2 IRQs to all of the ports, thus raising the possibility of IRQ sharing problems.&nbsp; I then moved the card to the 1st slot, and it was then able to obtain a unique IRQ for each port.&nbsp; After I disabled the system's built-in ethernet (which also claimed an IRQ used by the Znyx card) and restarted the traffic flow, I noticed that the loss decreased about 0.2%.</FONT></P>

<P><FONT SIZE=2>I've also tried replacing the card with no change.</FONT>
</P>

<P><FONT SIZE=2>Any ideas?</FONT>
</P>

<P><FONT SIZE=2>Cheers!</FONT>
<BR><FONT SIZE=2>Jon</FONT>
</P>

</BODY>
</HTML>
\
 
 \ /
  Last update: 2005-03-22 12:38    [W:0.024 / U:1.208 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site