lkml.org 
[lkml]   [2000]   [Sep]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: PATCH 2.4.0.9.4: Fix Cardbus
Dag Bakke wrote:
>
> Jeff Garzik wrote:
>
> > Ok, it's time to get test9 running on my laptop, so I played the "what
> > code didn't get cut-n-pasted" game.
> >
> > With the attached tested patch against 2.4.0-test9-pre4, CardBus is
> > working again for me. This patch makes the logic match that of the old
> > code.
>
> Well.
> Still doesn't work for me. So I tested 2.2.17 and pcmcia-cs 3.1.20.
>
> # lsmod
> Module Size Used by
> tulip_cb 32092 0 (unused)
> cb_enabler 2504 1 [tulip_cb]
[...]
> cs: cb_alloc(bus 35): vendor 0x115d, device 0x0003
>
> [/etc/init.d/pcmcia start]
> cs: IO port probe 0x0c00-0x0cff: clean.
> cs: IO port probe 0x0800-0x08ff: clean.
> cs: IO port probe 0x0100-0x04ff: clean.
> cs: IO port probe 0x0a00-0x0aff: clean.
> ROM image dump:
> cs: no valid ROM images found!
>
> Same problem, or different problem? This time, the card is not even
> detected...

Look around for patches from Keith Owens relating to this, and the
xircom_tulip_cb driver. It needs a ROM image mapping into the address
space, which is normally not done without the special "pci=rom" setting
on the kernel command line. Keith's patch, IIRC, temporary does a
mapping in order to get the necessary information from the ROM image.

Jeff
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:38    [W:0.051 / U:2.084 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site