lkml.org 
[lkml]   [2000]   [Sep]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: test9-pre1 hang when loading scsi-ide cdrom
On Sat, Sep 16, 2000 at 07:27:01PM +0200, Frank van de Pol wrote:
>
> Just experienced a (reproducable) hang of the system when loading the
> drivers for my cdrom drives. (ide-cd and ide-scsi). System freezes
> completely; interupts / alt-sysreq is still working.
>
> Just before the lockup I get next message on my console:
>
> "
> scsi1 : SCSI host adapter emulation for IDE ATAPI devices
> scsi : 2 hosts.
> Vendor: E-IDE Model: CD-ROM 36X/AKU Rev: U21I
> Type: CD-ROM
> ANSI SCSI revision: 02
> Detected scsi CD-ROM sr0 at scsi1, channel 0, id 0, lun 0
> "
> <lockup....>

I tried to compile the sr_mod without the __init & __exit but this did (as
expected) to cure the problem.

The problem seems to reside in the ide-scsi driver; if the cdrom (sr_mod) is
not loaded, I get during initialisation of the ide-scsi module a lockup
after printing the information about the 1st host (dies after the 'Type:
CDROM' line). Probing the 2nd host seems to fail.

Frank.
--
+---- --- -- - - - -
|Frank van de Pol -o)
| FvdPol@home.nl /\\
| _\_v
|Linux - Why use Windows, since there is a door?
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:39    [W:0.066 / U:9.972 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site