lkml.org 
[lkml]   [2000]   [Aug]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
Subjectgenhd.c?
From

I recently decided to take a look at the partition code, which I could recall
being in drivers/block/genhd.c. Looking there, I had the surprise to see it had
only one function, whose beggining was:

void __init device_init(void)
{
#ifdef CONFIG_PARPORT
parport_init();
#endif
chr_dev_init();
blk_dev_init();
sti();

This clearly doesn't belong into drivers/block! And genhd.c is a completely
misleading name for it (unless you think the comment pointing at fs/partitions
is the most important part of it).

So I think it should be moved to init/ with a new name (init.c?), or maybe even
moved inside main.c (which I think would be the ideal fix).

--
Cesar Eduardo Barros
cesarb@nitnet.com.br
cesarb@dcc.ufrj.br
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:38    [W:0.053 / U:0.752 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site