lkml.org 
[lkml]   [2000]   [Aug]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: eepro100 status?
On Mon, 21 Aug 2000, Tony Hoyle wrote:

> Tigran Aivazian wrote:
> >
> > On Sun, 20 Aug 2000, Tony Hoyle wrote:
> >
> > > I notice the eepro100 driver still has the 'device reports no resources'
> > > bug. Does a fix exist for this?
> > >
> > > Tony
> >
> > isn't it just for stats, like running ifconfig(8) under very high load?
> >
> No, when this error is generated it stops the card working, and you have
> to
> ifconfig down/up the interface to reinitialise it.
>

Not for me. I have lots of these errors on a dual port 82557 eepro100 with
both ports extremely busy, when running ifconfig just to dump the
stats. And the ports continued running just fine after the errors. I.e. I
didn't need to down/up the interfaces.. If you look at the code, there is
a possibility there to restart the receiver and _not_ to do so. Perhaps in
your case it restarts it and in mine, it doesn.

Is there a datasheet for eepro100 (or at least for 82557 chipset?)
somewhere? It would be interesting to understand what status 8 actually
means.

Regards,
Tigran

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:37    [W:0.075 / U:22.988 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site