lkml.org 
[lkml]   [2000]   [Aug]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectOut of Memory? - Correction
I just realized I made a few errors/omissions in my previous post.
Here is what I should've said -
In console mode, as a normal user, I tried to open a 22mb file
on my Slackware 7.1 (kernel 2.2.16) system. Pico displayed reading
file for a short time, and then switched to "cannot allocat 32bytes",

and a second later "cannot allocate 48 bytes".

I switched to VT2, and tried to login as root. After I typed root, I got the following

/bin/login - error in loading shared libraries libcrypt.so - failed to map memory segment from shared object - cannot allocate memory

and then init : id c2 respawning too fast,: disabled for 5 minutes

on VT3, same thing, except an additional message

/bin/agetty - error in loading shared libraries libc.so.6 - cannot allocate zero fillpages - cannot allocate memory

and then the init : id etc. message for c3. The exact same output on VT4 and beyond, except cannot allocate zero fillpages appeared in place of failed to map - etc for the first error message. Sorry for the bad grammar, but I am in a hurry to get somewhere.

MY machine = pentium 700 128mb ram. I have duplicated this error three times on the same machine, and can supply you with any required info.



-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:37    [W:0.018 / U:4.144 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site