lkml.org 
[lkml]   [2000]   [Aug]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectOut of memory?
I just experienced a strange situation on my slackware 7.1, kernel
2.2.16 box. I was compiling windowmaker on VT1, and experimenting with
a prime number generation tool on VT2. I tried to open a 26mb file with
pico, but because it was so large pico took a while to open it,
displaying reading file on the bottom of the screen. I switched back to
VT1, and noticed that the build had slowed to a crawl. Puzzled, I sat
back and waited. After about 30 seconds, make crashed with an out of
memory error. I typed at the command line "clear" to clear the screen,
but it complained about not being able to map memory pages to open
libc6. I switch back to VT2, and found the pico was still "reading
file". On vt1, every command, including shutdown, didn't start because
of not being able to open a shared library. killall pico (in the hopes
that killing it would free up the memory it stole) crashed with a
segfault. I tried to login on VT3, but after typing root and the
password and enter, I got the following message
"init: Id "c3" respawning too fast; disabled for 5 minutes"
Eventually, the same thing happened on my other VTs. Finally, after a
few minutes, pico finally crashed, or exited, or whatever, and I was
able to restart normally. I haven't tried to reproduce the error, but
I could if so desired. The only messages in the system log are the
above message for c3, c1 and c4 one time each.

Isn't the kernel supposed to prevent this sort of this from
happening?

--A. Valys

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:37    [W:0.045 / U:5.088 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site