lkml.org 
[lkml]   [2000]   [Aug]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectide-scsi, ide cdwriter
I'am trying to get my plextor IDE cd-writer to function in write mode
but I have some ploblems.

kernel version is 2.4.0-test7-pre5 and Cdrecord 1.8.

The drive is detected by the ide-scsi

scsi0 : SCSI host adapter emulation for IDE ATAPI devices
scsi : 1 host.
Vendor: PLEXTOR Model: CD-R PX-W8432T Rev: 1.05
Type: CD-ROM ANSI SCSI revision: 02
Detected scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
Vendor: PIONEER Model: DVD-ROM DVD-104F Rev: 2.02
Type: CD-ROM ANSI SCSI revision: 02
Detected scsi CD-ROM sr1 at scsi0, channel 0, id 1, lun 0
scsi : detected 2 SCSI cdroms total.
sr0: scsi3-mmc drive: 32x/32x writer cd/rw xa/form2 cdda tray
Uniform CD-ROM driver Revision: 3.11
sr1: scsi3-mmc drive: 0x/0x cd/rw xa/form2 cdda tray

But when "cdrecord -scanbus" tries to open the sg device to scan the bus
none is working.

A regular mount of sr0 or sr1 works OK.

I have never tried using a cd writer under linx before so I don't know
how it's supposed to work but this looks like some type of kernel bug to
me.



ps. is not the scsi system a bit to easy ? I mean after two three hours
you almost get it. we have sd sg st scd nst devices that I could find
all with interesting indexing, The concept of naming a device d: lookes
in comparison like a stroke of genius.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:37    [W:0.029 / U:23.308 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site