lkml.org 
[lkml]   [2000]   [Jul]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: IDE read problem with ht6560a fixed in ide- patches only

That is when I added the Ultra ATA/100 support.
Also, I am working arrival stuff for non-pci stuff now.

On Sat, 15 Jul 2000, Petr Soucek wrote:

> Hi,
> I've compiled about 10 various kernels so I have some additional
> information. IDE patches upto ide.2.2.16 (dd. 2000-06-15) solve the
> problem with ht6560a, but newer patches starting ide.2.2.16.20000619
> not.
>
> So Andre, what may be the cause? What was so special on your patches
> till 15-Jun-2000? I did a diff between these versions and it has
> almost 200KB, so I'm not able to guess what difference is fatal.
>
> On 15 Jul 2000, at 13:37, Petr Soucek wrote:
>
> > my 486 box with Holtek HT6560A ide vlb controller works only with 2.2
> > kernel with Andre Hedrick's patches - I tested 2.2.15 and 2.2.17pre4
> > and both work fine.
> >
> > But 2.2.17pre4, 2.2.12 (Redhat), 2.3.99pre6, 2.4.0-test2 ends with
> > the same error during reading partition table:
> >
> > Uniform Multi-Platform E-IDE driver Revision: 6.31
> > ide: Assuming 50MHz system bus speed for PIO modes; override with
> > idebus=xx
> > hda: WDC AC24300L, ATA DISK drive
> > hdb: WDC AC36400L, ATA DISK drive
> > ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
> > hda: 8421840 sectors (4312 MB) w/256KiB Cache, CHS=557/240/63
> > hdb: 12594960 sectors (6449 MB) w/256KiB Cache, CHS=833/240/63
> > Partition check:
> > hda:hda: status timeout: status=0xff { Busy }
> > hda: drive not ready for command
> > ide0: reset timed-out, status=0xff
> > hda: status timeout: status=0xff { Busy }
> > hda: drive not ready for command
> > ide0: reset timed-out, status=0xff
> > hda: status timeout: status=0xff { Busy }
> > end_request: I/O error, dev 03:00 (hda), sector 0
> > hda: drive not ready for command
> > unable to read partition table
> > hdb:hdb: status timeout: status=0xff { Busy }
> > hdb: drive not ready for command
> > ide0: reset timed-out, status=0xff
> > hdb: status timeout: status=0xff { Busy }
> > hdb: drive not ready for command
> > ide0: reset timed-out, status=0xff
> > hdb: status timeout: status=0xff { Busy }
> > end_request: I/O error, dev 03:40 (hdb), sector 0
> > hdb: drive not ready for command
> > unable to read partition table
> >
> > (the same behavior both with and without ide0=ht6560b)
> >
> > With Andre's patches both disks works fine, but there is another
> > problem, false "ports already in use":

This is minor, the other two are major.

> > Uniform Multi-Platform E-IDE driver Revision: 6.30
> > ide: Assuming 50MHz system bus speed for PIO modes; override with
> > idebus=xx
> > hda: WDC AC24300L, ATA DISK drive
> > hdb: WDC AC36400L, ATA DISK drive
> > ide1: ports already in use, skipping probe
> > ide2: ports already in use, skipping probe
> > ide3: ports already in use, skipping probe
> > ide4: ports already in use, skipping probe
> > ide5: ports already in use, skipping probe
> > ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
> > hda: WDC AC24300L, 4112MB w/256kB Cache, CHS=557/240/63
> > hdb: WDC AC36400L, 6149MB w/256kB Cache, CHS=833/240/63
> > .... other devices initialization
> > Partition check:
> > sda: sda1 sda2 sda3
> > hda: [PTBL] [524/255/63] hda1 hda2 < hda5 >
> > hdb: [PTBL] [784/255/63] hdb1 hdb2 < hdb5 >
> >
> > For completeness, this is clean 2.2.17pre4 kernel:
> >
> > hda: WDC AC24300L, ATA DISK drive
> > hdb: WDC AC36400L, ATA DISK drive
> > ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
> > hda: WDC AC24300L, 4112MB w/256kB Cache, CHS=557/240/63
> > hdb: WDC AC36400L, 6149MB w/256kB Cache, CHS=833/240/63
> > .....
> >
> > Partition check:
> > sda: sda1 sda2 sda3
> > hda:hda: status timeout: status=0xff { Busy }
> > hda: drive not ready for command
> > ide0: reset timed-out, status=0xff
> > hda: status timeout: status=0xff { Busy }
> > hda: drive not ready for command
> > ide0: reset timed-out, status=0xff
> > hda: status timeout: status=0xff { Busy }
> > end_request: I/O error, dev 03:00 (hda), sector 0
> > hda: drive not ready for command
> > unable to read partition table
> > hdb:hdb: status timeout: status=0xff { Busy }
> > hdb: drive not ready for command
> > ide0: reset timed-out, status=0xff
> > hdb: status timeout: status=0xff { Busy }
> > hdb: drive not ready for command
> > ide0: reset timed-out, status=0xff
> > hdb: status timeout: status=0xff { Busy }
> > end_request: I/O error, dev 03:40 (hdb), sector 0
> > hdb: drive not ready for command
> > unable to read partition table
> >
> > It seems the wrong behavior was fixed in ide-2.2..... patches, but
> > not in both 2.2. and 2.4 mainstream kernel.

This is bad because ide-2.2..... =(should)= 2.4 mainstream.
> > Best Regards,
> >
> >
> > Petr Soucek
> > Ryston Electronics s.r.o
> > petr@ryston.cz http://www.ryston.cz/
> >
> > -
> > To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> > the body of a message to majordomo@vger.rutgers.edu
> > Please read the FAQ at http://www.tux.org/lkml/
>
>
> Petr Soucek
> Ryston Electronics s.r.o.
> Modranska 621/72
> CZ-143 00 Praha 4, Czech Republic
> tel +420-2-61302222 fax +420-2-61302211
> Email: petr@ryston.cz http://www.ryston.cz
>

Andre Hedrick
The Linux ATA/IDE guy


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:57    [from the cache]
©2003-2011 Jasper Spaans