lkml.org 
[lkml]   [2000]   [Mar]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Linux Jobs: Update
Q wrote:
>
> On Sun, Mar 12, 2000 at 09:17:28PM +0100, Kjartan Maraas wrote:
> > Gerhard Mack wrote:
> > >
> > > On Sun, 12 Mar 2000, Alan Cox wrote:
> > >
> > > > > Sound initialization started
> > > > > <Sound Blaster 16 (4.13)> at 0x220 irq 5 dma 1,5
> > > > > <Sound Blaster 16> at 0x330 irq 5 dma 0
> > > > > <Yamaha OPL3> at 0x388
> > > > > Sound initialization complete
> > > >
> > > > You compiled in values
> > > >
> > > > > adlib: must specify I/O address.
> > > > > Soundblaster audio driver Copyright (C) by Hannu Savolainen 1993-1996
> > > > > sb_card: I/O, IRQ, and DMA are mandatory
> > > >
> > > > You didnt set values on the command line instead of compiled in
> > > >
> > >
> >
> > This is described in Configure.help I think. It's now a kernel command
> > line option.
>
> I added "sb=0x220,7,1,5" now, and it seems to work (I got music). Got this
> is startup:
>
> Soundblaster audio driver Copyright (C) by Hannu Savolainen 1993-1996
>
> nothing more. Why doesn't it report the port and irq/dma anymore?
>
> Only have 1 question left. Where is the option to set the MPU's port now?
>
From looking at the source, it seems to me that the sb driver attaches
to the mpu401 code and you will have to specify mpu401=<io>,<irq>
on the kernel command line as well.

Cheers
Kjartan Maraas

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:57    [from the cache]
©2003-2011 Jasper Spaans