lkml.org 
[lkml]   [2000]   [Dec]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Problems with Athlon CPU
In article <Pine.LNX.4.30.0012042315410.620-100000@asdf.capslock.lan> you wrote:
> ^^^^^^^^^^^^^^^^

> You can't build a kernel with that compiler. You _must_ use gcc
> 2.91.66 or another compiler that can compile the kernel. Red Hat
> ships gcc 2.91.66 packaged as "kgcc" for kernel builds as do
> other major vendors.

Huh, no way, I have tried also with kgcc:
[root@beer linux]# cat Makefile |grep gcc
HOSTCC =kgcc
# foo-bar-gcc for cross builds
# gcc272 for Debian's old compiler for kernels
# kgcc for Conectiva and Red Hat 7
CC =$(shell if [ -n "$(CROSS_COMPILE)" ]; then echo $(CROSS_COMPILE)kgcc; else \
$(CONFIG_SHELL) scripts/kwhich gcc272 2>/dev/null || $(CONFIG_SHELL) scripts/kwhich kgcc 2>/dev/null || echo cc; fi) \

after make bzImage:

/usr/src/linux/include/linux/signal.h: In function `siginitsetinv':
/usr/src/linux/include/linux/signal.h:201: parse error before `)'
/usr/src/linux/include/linux/signal.h:201: parse error before `)'
/usr/src/linux/include/linux/signal.h:201: parse error before `)'
/usr/src/linux/include/linux/signal.h:201: parse error before `)'
/usr/src/linux/include/linux/signal.h:201: parse error before `)'
/usr/src/linux/include/linux/signal.h:201: parse error before `)'
/usr/src/linux/include/linux/signal.h:201: parse error before `)'
/usr/src/linux/include/linux/signal.h:201: parse error before `)'
/usr/src/linux/include/linux/signal.h:201: parse error before `)'
/usr/src/linux/include/linux/signal.h:201: parse error before `)'
/usr/src/linux/include/linux/signal.h:201: parse error before `)'
/usr/src/linux/include/linux/signal.h:201: parse error before `)'
make[3]: *** [auto_irq.o] Error 1
make[3]: Leaving directory `/usr/src/linux/drivers/net'
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory `/usr/src/linux/drivers/net'
make[1]: *** [_subdir_net] Error 2
make[1]: Leaving directory `/usr/src/linux/drivers'
make: *** [_dir_drivers] Error 2

and I would like also to say, that problem doeas not exists with glibc
and glibc-devel 2.1.94.

--
*[ Łukasz Trąbiński ]*
SysAdmin @wsisiz.edu.pl
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:51    [W:0.052 / U:0.580 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site