lkml.org 
[lkml]   [2000]   [Dec]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: path MTU bug still there?
On Sun, 31 Dec 2000, Jussi Hamalainen wrote:

> I'm running 2.2.18 vanilla and my firewall rules aren't blocking
> ICMP. The ethernet interfaces and the ISDN link have an MTU of
> 1500 and the GRE tunnel has an MTU of 1514 (courtesy of Cisco).

How is this solved? Personally, I am behind a CIPE tunnel with an MTU of
1442 or something like that. I experienced problems to some places and
have solved it by using the linux box as socks5 proxy (only napster) and
webproxy (squid). When the linux box does TCP to the outside it'll use the
MTU of the tunnel (default route is the tunnel) and thus works perfectly
(since TCP MSS will be set low enough to fit into the tunnel).

Could it be some kind of incompability at the tunnel level that make you
unable to receive large packets over the tunnel? Have you tcpdump:ed to
see if the tunnel packets actually make it the way they should?

--
Mikael Abrahamsson email: swmike@swm.pp.se

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:52    [W:0.064 / U:3.224 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site