lkml.org 
[lkml]   [2000]   [Dec]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectProblems with CDROMVOLCTRL
Date
From
Hi,
CDROMVOLCTRL does not work with my configuration in test11.
The ioctl always returns an error and volume stays the same
(seen with xmcd and gtcd). I tried the patch at

*.kernel.org/pub/linux/kernel/people/axboe/patches/2.4.0-test11/cd-1.bz2

This changed the error code from some bogus large positive number
to -EOPNOTSUPP :) However, volume control works fine in 2.2.17,
so the hardware shouldn't be the culprit.
The cdrom drive in question is an old TEAC CD-56S on an
Adaptec AHA-2940 (narrow) controller.

Cheers, Roderich
--
There is something to be learned from a rainstorm. When meeting with
a sudden shower, you try not to get wet and run quickly along the road.
But doing such things as passing under the eaves of houses, you still
get wet. When you are resolved from the beginning, you will not be
perplexed, though you still get the same soaking.

-- Hagakure - The Book of the Samurai

Roderich Schupp mailto:rsch@ExperTeam.de
ExperTeam GmbH http://www.experteam.de/
Munich, Germany

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:51    [W:0.031 / U:0.732 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site