lkml.org 
[lkml]   [2000]   [Dec]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: multiprocessor kernel problem
Date
Rusty Russell <rusty@linuxcare.com.au> writes:

> In message <3A27D4D6.4DA47346@lanl.gov> you write:
> >
> > I have 2.4.0 test 10 and test 11 installed on a multiprocessor (Intel)
> > machine. I have tried both test versions of the kernel. I configured
> > the kernel for single
> > and multi processor. When I boot single processor, iptables will run
> > fine. When I boot the machine with the multiprocessor kernel and run
> > iptables, the kernel dumps several pages of hex and the final two lines
> > of output are:
> >
> > Killing interrupt handler
> > scheduling in interrupt
>
> My development box (running test10pre5) is SMP, and it works fine.

yes, but is it a dual machine or is it an N-way SMP with N > 2? the
other guy with iptables/SMP problems also has a quad box. could this
perhaps be a problem only when you have more than two processors?

> I
> haven't updated to the latest kernel version because I like my
> filesystems in one piece, and the netfilter code hasn't changed.
>
> What is your kernel configuration, and iptables version? Have you
> patched the kernel?

i tried 2.4.0-test10 (no patches) with iptables 1.1.2. this is an alr
revolution quad6 (4 ppros).

i posted this to the netfilter mailing list a while back.
<URL:http://lists.samba.org/pipermail/netfilter/2000-November/005838.html>

--
J o h a n K u l l s t a m
[kullstam@ne.mediaone.net]
Don't Fear the Penguin!
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:51    [W:0.105 / U:2.648 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site