lkml.org 
[lkml]   [2000]   [Dec]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject(REPOST-sorry) PCI VIA IDE Strangeness w/2.4.0-test12/test13-pre5
REPOST: People have asked me to repost this message because their e-mail clients
don't wrap lines. I'd like to know which ones don't, but this isn't the list
for that kind of question, unless it is, which then means I'm posting to the
wrong list to start with and then I wouldn't have to repost. Anyways...

---(CC answer please)---

I'm having a strange problem with my IDE controller. I believe (and that's
what Windows and the m/b manufaturer -- PC Chips -- say) that I have a VIA PCI
BusMaster IDE controller, and I've had some strange history with it. I've
asked many people before on various help services, and I was able to fix my
problem with the 2.2 series, but now my fix does not work.

THE PROBLEM:
------------

Ever since the 2.2 kernel series (I remeber this working properly in 2.0.36,
without the conflicts), I would get hdc: lost interrupt during boot up, and my
system would take bloody ages to boot up and load a CD. I tracked it down to a
strange IRQ conflict in which Linux would try to assign both the primary and
secondary IDE channels IRQ 14, causing IRQ conflicts galore. I was able to fix
this by giving the kernel

ide1=0x170,0x376,15

at boot time. This has worked for 2.2.12-.17 and Alan's 2.2.18pre21 (I haven't
compiled the official 2.2.18 yet, but I'm sure it will work).

I wanted to try the new 2.4.0-test series, and the first I tried was -test11,
and from what I recall (other things weren't working properly then), this fix
still worked, but now, with -test12, I am now getting the following error
repeated for a very long time (then I reboot) with the same parameters:

ide_dmaproc: chipset supported ide_dma_lostirq func only: 13
hdb: lost interrupt

Also, I get "spurious 8259A interrupt: IRQ 7" if I leave it for a while. I
tried -test13-pre5 on somebody on #KernelNewbies' suggestion, and I get the
same error. Scrolling up, I see that the kernel messages show that ide0 is on
IRQ 14 and ide1 is on 15. I noticed that hda is using DMA, and hdb is using
UDMA33, but I don't believe that that is the problem.

THE QUESTION:
-------------

How do I fix this, or is it a (un)known problem in the newer development
versions? If you have the answer, could you please CC me as well for I don't
subscribe to this mailing list (sorry!). Thanks a bunch.
--
| Evan A. Thompson | He's more fun than trying to skinny |
| evaner@bigfoot.com | dip in the beach in winter... |
| http://evaner.penguinpowered.com | ...in Winnipeg. |
| ICQ: 2233067 / AIM + MSN: Evaner517 | (GnuPG key avaiable upon request.) |
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:52    [W:0.037 / U:0.380 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site