[lkml]   [2000]   [Dec]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: multiprocessor kernel problem
Roger Crandell <> writes:

> I have 2.4.0 test 10 and test 11 installed on a multiprocessor (Intel)
> machine. I have tried both test versions of the kernel. I configured
> the kernel for single
> and multi processor. When I boot single processor, iptables will run
> fine. When I boot the machine with the multiprocessor kernel and run
> iptables, the kernel dumps several pages of hex and the final two lines
> of output are:
> Killing interrupt handler
> scheduling in interrupt
> The kernel logs nothing and you must reset the machine to bring it back
> up. I believe this is a kernel issue rather than an iptables
> issue.
> Does anyone have experience with iptables on a multiprocessor
> machine?

i tried it about a month back with -test11. my quad ppro simply
locked up and died when i issued "iptables -nL". i got no logs just a
freeze. perhaps only my keyboard mouse and NIC died and the rest of
the machine kept on running. i posted a couple of times to the
netfilter mailing list but got zero response.

J o h a n K u l l s t a m
Don't Fear the Penguin!
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
Please read the FAQ at

 \ /
  Last update: 2005-03-22 12:51    [W:0.072 / U:0.768 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site