lkml.org 
[lkml]   [2000]   [Dec]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [linux-usb-devel] PROBLEM: USB (MS Intellimouse specifically) does not work with SMP Linux 2.2.18.
On Tue, Dec 12, 2000, Laramie Leavitt <lar@cs.york.ac.uk> wrote:
> [1.] One line summary of the problem:
> USB (MS Intellimouse specifically) does not work with SMP kernel 2.2.18.
>
> [2.] Full description of the problem/report:
> When trying to install a Microsoft Intellimouse Explorer (USB)
> to a SMP kernel, I get the following error multiple times:
>
> usb.c: USB device not accepting new address (error=-110)
>
> If USB is compiled in, then it happens several times during the
> boot sequence.
>
> Everything works fine on a single-processor kernel. I have tried
> installing all of USB as modules, and I have tried compiling it
> into the kernel with no change.
>
> System is a MSI 694D-Pro AR motherboard (Via 694X chipset)
> Dual 500 Mhz Celeron processors, 500 Mhz (Not overclocked)
> Microsoft Intellimouse explorer.
>
> I suspect that it is an issue where locking is required,
> but none currently exists, either in mousedev, usb, or
> uhci. (Great logic--those are the main modules that should
> be in use.) I suspect that the problem can be duplicated
> on my system under Linux 2.4.0-test11, but, alas, I cannot
> get linux 2.4 to boot right now.
>
> I don't see the hid module in the status output like I do on
> the uni-processor kernel. Maybe those structures need locks.

Unlikely. Many people use that particular mouse with your particular HCD
in SMP every day. Like myself. In fact I am right now, using 2.2.18.

What is more likely the cause is an IRQ routing problem.

Can you check /proc/interrupts and see if the interrupt count is going
up?

Also, can you check your BIOS and see if it is configured for MPS 1.4?
If so, change it to MPS 1.1.

JE

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:28    [W:0.059 / U:1.988 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site