lkml.org 
[lkml]   [2000]   [Dec]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.2.18pre24 and drm/agpgart static?
On Fri, Dec 01, 2000 at 09:22:22PM -0600, Peter Samuelson wrote:
>
> [Jamie Manley]
> > Yes, modversions was enabled. Should that be affecting the build of
> > the kernel proper?
>
> The bug you ran into is that MODVERSIONS messes up the
> 'get_module_symbol' function, which is a sort of "optional dependency"
> mechanism used by a few modules such as DRI (in this case: DRI needs to
> be able to use the facilities of agpgart, but should also work
> *without* agpgart present, since many systems have PCI video cards).

Of course, PCI and DRI shouldn't be mutually exclusive. Glad to hear
it's being worked on.

>
> MODVERSIONS is ugly and gross for any number of reasons, but the
> get_module_symbol problem is quite localized -- AGP/DRI, MTD and maybe
> one or two other subsystems. In any case it has been replaced by a
> much better inter-module registration system in 2.4.
>
> Peter

I guess that means I should start testing 2.4.0test* on this machine
:) Thanks for the background.

Jamie

--
Jamie http://www.intermag.com
And I said, "This must be the place." -- Laurie Anderson, "Big Science"
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:51    [W:0.058 / U:0.420 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site