lkml.org 
[lkml]   [2000]   [Nov]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [HARDLOCK] 2.2.17 locks up hard on Ultra66/PDC20262 in DMA mode when using ide + raid-A0 + eepro100 patches
UPDATE:

Even with hdparm -d0 /dev/hde (to disable the DMA), I'm still getting:

hde: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hde: dma_intr: error=0x10 { SectorIdNotFound }, LBAsect=15347359,
sector=15347328
hde: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hde: dma_intr: error=0x10 { SectorIdNotFound }, LBAsect=15347359,
sector=15347328
hde: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hde: dma_intr: error=0x10 { SectorIdNotFound }, LBAsect=15347359,
sector=15347328
hde: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hde: dma_intr: error=0x10 { SectorIdNotFound }, LBAsect=15347359,
sector=15347328

But now I don't get the
hde: DMA disabled
error message anymore. But it still locks really hard. Also, I noticed
that you can't disable the "Use DMA by default" option in the kernel
without losing the "Promise PDC202xx" driver option. So how do I disable
DMA in the kernel for this promise card (and the pii4x mb as
well)? Because it doesn't seem like hdparm -d0 is helping.

Any other ideas guys?


On Mon, 6 Nov 2000, Dan Browning wrote:

> Dear Hackers, IDE gods, and promise driver writers:
>
> [1.] One line summary of the problem:
> 2.2.17 locks up hard on Ultra66/PDC20262 in DMA mode when using ide +
> raid-A0 + eepro100 patches
>
> [2.] Full description of the problem/report:
> I'm running 2.2.17 (+ide+raid+eepro100 patches) with "/" on a RAID-5
> volume over 4 disks (Seagate barracudas). Two of the disks (hde +
> hdg) are on a Promise Ultra66 (PDC20262) IDE card with bios 2.00b18.
> It seems that between 30 minutes and 4 hours of the system running,
> this happens:
>
> hde: dma_intr: status=0x51 { DriveReady SeekComplete Error }
> hde: dma_intr: error=0x10 { SectorIdNotFound }, LBAsect=15347359,
> sector=15347328
> hde: dma_intr: status=0x51 { DriveReady SeekComplete Error }
> hde: dma_intr: error=0x10 { SectorIdNotFound }, LBAsect=15347359,
> sector=15347328
> hde: dma_intr: status=0x51 { DriveReady SeekComplete Error }
> hde: dma_intr: error=0x10 { SectorIdNotFound }, LBAsect=15347359,
> sector=15347328
> hde: dma_intr: status=0x51 { DriveReady SeekComplete Error }
> hde: dma_intr: error=0x10 { SectorIdNotFound }, LBAsect=15347359,
> sector=15347328
> hde: DMA disabled
>
> What do these errors mean?
>
> At this point, the system is locked up very hard. The three finger
> salute doesn't even work. This has happened three times so far.
> Sometimes during activity, other times during idle. Actually, it
> never was *really* idle, since it was always sync'ing the RAID5 array
> (takes a while to build the parity for 50gb).
>
> Now as far as DMA, temporarily I have disabled the DMA with
> 'hdparm -d0 /dev/hde'. So far it hasn't crashed with dma disabled,
> but I'm disappointed to lose that performance. Should I try the
> 2.2.18pre18 + ide + raid-2 patches? (Last time I tried, before the
> pre18 came out, I couldn't get the raid-2 mingo patches to apply
> cleanly).
>
> FYI, here is a 'hdparm -i /dev/hda'
>
> /dev/hde:
>
> Model=ST320420A, FwRev=3.21, SerialNo=3CL0K8TA
> Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs RotSpdTol>.5% }
> RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=0
> BuffType=unknown, BuffSize=2048kB, MaxMultSect=16, MultSect=off
> CurCHS=16383/16/63, CurSects=-66060037, LBA=yes, LBAsects=39851760
> IORDY=on/off, tPIO={min:240,w/IORDY:120}, tDMA={min:120,rec:120}
> PIO modes: pio0 pio1 pio2 pio3 pio4
> DMA modes: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 *udma4
>
> [4.] Kernel version (from /proc/version):
> Linux version 2.2.17-RAID (root@localhost.localdomain) (gcc version
> egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)) #1 Sat Nov 4
> 19:33:20 PST 2000
>
> [7.] Environment
> Intel D815EEAL mb (bios P07)
> 800Mhz P3 / 256mb ram
> six 24" high quality udma66 ide cables.
> 4 seagate ST320420A's
> Promise Ultra 66(PDC20262) IDE card with bios 2.00b18
> Enlight 8950 case-- massive fans. Plus each hdd is mounted with $20
> heat sink+ 2fans blowing air directly over the hdds. (i.e. Not a
> thermals problem).
>
> [7.1.] Software (add the output of the ver_linux script here)
> Linux server 2.2.17-RAID #1 Sat Nov 4 19:33:20 PST 2000 i686 unknown
> Kernel modules 2.3.14
> Gnu C 2.96
> Binutils 2.10.0.18
> Linux C Library 2.1.94
> Dynamic linker ldd (GNU libc) 2.1.94
> Procps 2.0.7
> Mount 2.10m
> Net-tools 1.56
> Console-tools 0.3.3
> Sh-utils 2.0
> Modules Loaded vmnet vmmon eepro100
>
> [7.2.] Processor information (from /proc/cpuinfo):
> processor : 0
> vendor_id : GenuineIntel
> cpu family : 6
> model : 8
> model name : Pentium III (Coppermine)
> stepping : 3
> cpu MHz : 797.588
> cache size : 256 KB
> fdiv_bug : no
> hlt_bug : no
> sep_bug : no
> f00f_bug : no
> coma_bug : no
> fpu : yes
> fpu_exception : yes
> cpuid level : 2
> wp : yes
> flags : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca
> cmov pat pse36 mmx fxsr xmm
> bogomips : 1592.52
>
> [7.3.] Module information (from /proc/modules):
> vmnet 16320 4
> vmmon 17824 1
> eepro100 16128 1 (autoclean)
>
> [7.5.] Other information that might be relevant to the problem
> (please look in /proc and include all information that you
> think to be relevant):
> /proc/
>
>
> [8.1] Other notes, patches, fixes, workarounds:
> FYI, my kernel config:
>
> #
> # Automatically generated by make menuconfig: don't edit
> #
>
> #
> # Code maturity level options
> #
> CONFIG_EXPERIMENTAL=y
>
> #
> # Processor type and features
> #
> # CONFIG_M386 is not set
> # CONFIG_M486 is not set
> # CONFIG_M586 is not set
> # CONFIG_M586TSC is not set
> CONFIG_M686=y
> CONFIG_X86_WP_WORKS_OK=y
> CONFIG_X86_INVLPG=y
> CONFIG_X86_BSWAP=y
> CONFIG_X86_POPAD_OK=y
> CONFIG_X86_TSC=y
> CONFIG_X86_GOOD_APIC=y
> CONFIG_1GB=y
> # CONFIG_2GB is not set
> # CONFIG_MATH_EMULATION is not set
> CONFIG_MTRR=y
> # CONFIG_SMP is not set
>
> #
> # Loadable module support
> #
> CONFIG_MODULES=y
> CONFIG_MODVERSIONS=y
> CONFIG_KMOD=y
>
> #
> # General setup
> #
> CONFIG_NET=y
> CONFIG_PCI=y
> # CONFIG_PCI_GOBIOS is not set
> # CONFIG_PCI_GODIRECT is not set
> CONFIG_PCI_GOANY=y
> CONFIG_PCI_BIOS=y
> CONFIG_PCI_DIRECT=y
> CONFIG_PCI_QUIRKS=y
> # CONFIG_PCI_OPTIMIZE is not set
> CONFIG_PCI_OLD_PROC=y
> # CONFIG_MCA is not set
> # CONFIG_VISWS is not set
> CONFIG_SYSVIPC=y
> # CONFIG_BSD_PROCESS_ACCT is not set
> CONFIG_SYSCTL=y
> CONFIG_BINFMT_AOUT=m
> CONFIG_BINFMT_ELF=y
> CONFIG_BINFMT_MISC=m
> # CONFIG_BINFMT_JAVA is not set
> # CONFIG_PARPORT is not set
> # CONFIG_APM is not set
> # CONFIG_TOSHIBA is not set
>
> #
> # Plug and Play support
> #
> CONFIG_PNP=y
>
> #
> # Block devices
> #
> CONFIG_BLK_DEV_FD=y
> CONFIG_BLK_DEV_IDE=y
> # CONFIG_BLK_DEV_HD_IDE is not set
> CONFIG_BLK_DEV_IDEDISK=y
> # CONFIG_IDEDISK_MULTI_MODE is not set
> CONFIG_BLK_DEV_IDECD=y
> CONFIG_BLK_DEV_IDETAPE=y
> # CONFIG_BLK_DEV_IDEFLOPPY is not set
> # CONFIG_BLK_DEV_IDESCSI is not set
> # CONFIG_IDE_TASK_IOCTL_DEBUG is not set
> # CONFIG_BLK_DEV_CMD640 is not set
> # CONFIG_BLK_DEV_RZ1000 is not set
> CONFIG_BLK_DEV_IDEPCI=y
> # CONFIG_IDEPCI_SHARE_IRQ is not set
> CONFIG_BLK_DEV_IDEDMA=y
> CONFIG_IDEDMA_AUTO=y
> CONFIG_IDEDMA_NEW_DRIVE_LISTINGS=y
> CONFIG_IDEDMA_PCI_EXPERIMENTAL=y
> # CONFIG_IDEDMA_PCI_WIP is not set
> # CONFIG_BLK_DEV_OFFBOARD is not set
> # CONFIG_BLK_DEV_AEC62XX is not set
> # CONFIG_BLK_DEV_ALI15X3 is not set
> # CONFIG_BLK_DEV_AMD7409 is not set
> # CONFIG_BLK_DEV_CMD64X is not set
> # CONFIG_BLK_DEV_CY82C693 is not set
> # CONFIG_BLK_DEV_CS5530 is not set
> # CONFIG_BLK_DEV_HPT34X is not set
> # CONFIG_BLK_DEV_HPT366 is not set
> CONFIG_BLK_DEV_PIIX=y
> # CONFIG_PIIX_TUNING is not set
> # CONFIG_BLK_DEV_OPTI621 is not set
> CONFIG_BLK_DEV_PDC202XX=y
> # CONFIG_PDC202XX_BURST is not set
> # CONFIG_BLK_DEV_SIS5513 is not set
> # CONFIG_BLK_DEV_TRM290 is not set
> # CONFIG_BLK_DEV_VIA82CXXX is not set
> # CONFIG_IDE_CHIPSETS is not set
> # CONFIG_IDEDMA_IVB is not set
> CONFIG_BLK_DEV_LOOP=m
> CONFIG_BLK_DEV_NBD=m
> CONFIG_BLK_DEV_MD=y
> CONFIG_AUTODETECT_RAID=y
> # CONFIG_MD_LINEAR is not set
> # CONFIG_MD_STRIPED is not set
> # CONFIG_MD_MIRRORING is not set
> CONFIG_MD_RAID5=y
> # CONFIG_MD_TRANSLUCENT is not set
> # CONFIG_MD_HSM is not set
> CONFIG_BLK_DEV_RAM=y
> CONFIG_BLK_DEV_RAM_SIZE=4096
> CONFIG_BLK_DEV_INITRD=y
> # CONFIG_BLK_DEV_XD is not set
> # CONFIG_BLK_DEV_DAC960 is not set
> CONFIG_PARIDE_PARPORT=y
> # CONFIG_PARIDE is not set
> CONFIG_BLK_DEV_IDE_MODES=y
> # CONFIG_BLK_CPQ_DA is not set
> # CONFIG_BLK_DEV_HD is not set
>
> #
> # Networking options
> #
> CONFIG_PACKET=y
> CONFIG_NETLINK=y
> CONFIG_RTNETLINK=y
> CONFIG_NETLINK_DEV=y
> CONFIG_FIREWALL=y
> CONFIG_FILTER=y
> CONFIG_UNIX=y
> CONFIG_INET=y
> # CONFIG_IP_MULTICAST is not set
> # CONFIG_IP_ADVANCED_ROUTER is not set
> # CONFIG_IP_PNP is not set
> CONFIG_IP_FIREWALL=y
> CONFIG_IP_FIREWALL_NETLINK=y
> CONFIG_NETLINK_DEV=y
> CONFIG_IP_TRANSPARENT_PROXY=y
> CONFIG_IP_MASQUERADE=y
> CONFIG_IP_MASQUERADE_ICMP=y
> CONFIG_IP_MASQUERADE_MOD=y
> CONFIG_IP_MASQUERADE_IPAUTOFW=m
> CONFIG_IP_MASQUERADE_IPPORTFW=m
> CONFIG_IP_MASQUERADE_MFW=m
> # CONFIG_IP_ROUTER is not set
> # CONFIG_NET_IPIP is not set
> # CONFIG_NET_IPGRE is not set
> CONFIG_IP_ALIAS=y
> # CONFIG_ARPD is not set
> CONFIG_SYN_COOKIES=y
> # CONFIG_INET_RARP is not set
> CONFIG_SKB_LARGE=y
> # CONFIG_IPV6 is not set
> # CONFIG_IPX is not set
> # CONFIG_ATALK is not set
> # CONFIG_X25 is not set
> # CONFIG_LAPB is not set
> # CONFIG_BRIDGE is not set
> # CONFIG_LLC is not set
> # CONFIG_ECONET is not set
> # CONFIG_WAN_ROUTER is not set
> # CONFIG_NET_FASTROUTE is not set
> # CONFIG_NET_HW_FLOWCONTROL is not set
> # CONFIG_CPU_IS_SLOW is not set
>
> #
> # QoS and/or fair queueing
> #
> # CONFIG_NET_SCHED is not set
>
> #
> # Telephony Support
> #
> # CONFIG_PHONE is not set
> # CONFIG_PHONE_IXJ is not set
>
> #
> # SCSI support
> #
> # CONFIG_SCSI is not set
>
> #
> # I2O device support
> #
> # CONFIG_I2O is not set
> # CONFIG_I2O_PCI is not set
> # CONFIG_I2O_BLOCK is not set
> # CONFIG_I2O_SCSI is not set
>
> #
> # Network device support
> #
> CONFIG_NETDEVICES=y
>
> #
> # ARCnet devices
> #
> # CONFIG_ARCNET is not set
> CONFIG_DUMMY=m
> CONFIG_BONDING=m
> # CONFIG_EQUALIZER is not set
> # CONFIG_ETHERTAP is not set
> # CONFIG_NET_SB1000 is not set
>
> #
> # Ethernet (10 or 100Mbit)
> #
> CONFIG_NET_ETHERNET=y
> # CONFIG_NET_VENDOR_3COM is not set
> # CONFIG_LANCE is not set
> # CONFIG_NET_VENDOR_SMC is not set
> # CONFIG_NET_VENDOR_RACAL is not set
> # CONFIG_RTL8139 is not set
> # CONFIG_NET_ISA is not set
> CONFIG_NET_EISA=y
> # CONFIG_PCNET32 is not set
> # CONFIG_AC3200 is not set
> # CONFIG_APRICOT is not set
> # CONFIG_CS89x0 is not set
> # CONFIG_DM9102 is not set
> # CONFIG_DE4X5 is not set
> # CONFIG_DEC_ELCP is not set
> # CONFIG_DEC_ELCP_OLD is not set
> # CONFIG_DGRS is not set
> CONFIG_EEXPRESS_PRO100=m
> # CONFIG_LNE390 is not set
> # CONFIG_NE3210 is not set
> # CONFIG_NE2K_PCI is not set
> # CONFIG_TLAN is not set
> # CONFIG_VIA_RHINE is not set
> # CONFIG_SIS900 is not set
> # CONFIG_ES3210 is not set
> # CONFIG_EPIC100 is not set
> # CONFIG_ZNET is not set
> # CONFIG_NET_POCKET is not set
>
> #
> # Ethernet (1000 Mbit)
> #
> # CONFIG_ACENIC is not set
> # CONFIG_HAMACHI is not set
> # CONFIG_YELLOWFIN is not set
> # CONFIG_SK98LIN is not set
> # CONFIG_FDDI is not set
> # CONFIG_HIPPI is not set
> # CONFIG_PPP is not set
> # CONFIG_SLIP is not set
> # CONFIG_NET_RADIO is not set
>
> #
> # Token ring devices
> #
> # CONFIG_TR is not set
> # CONFIG_NET_FC is not set
> # CONFIG_RCPCI is not set
> # CONFIG_SHAPER is not set
>
> #
> # Wan interfaces
> #
> # CONFIG_HOSTESS_SV11 is not set
> # CONFIG_COSA is not set
> # CONFIG_SEALEVEL_4021 is not set
> # CONFIG_SYNCLINK_SYNCPPP is not set
> # CONFIG_LANMEDIA is not set
> # CONFIG_COMX is not set
> # CONFIG_HDLC is not set
> # CONFIG_DLCI is not set
> # CONFIG_SBNI is not set
>
> #
> # Amateur Radio support
> #
> # CONFIG_HAMRADIO is not set
>
> #
> # IrDA (infrared) support
> #
> # CONFIG_IRDA is not set
>
> #
> # ISDN subsystem
> #
> # CONFIG_ISDN is not set
>
> #
> # Old CD-ROM drivers (not SCSI, not IDE)
> #
> # CONFIG_CD_NO_IDESCSI is not set
>
> #
> # Character devices
> #
> CONFIG_VT=y
> CONFIG_VT_CONSOLE=y
> CONFIG_SERIAL=y
> # CONFIG_SERIAL_CONSOLE is not set
> # CONFIG_SERIAL_EXTENDED is not set
> # CONFIG_SERIAL_NONSTANDARD is not set
> CONFIG_UNIX98_PTYS=y
> CONFIG_UNIX98_PTY_COUNT=256
> CONFIG_MOUSE=y
>
> #
> # Mice
> #
> # CONFIG_ATIXL_BUSMOUSE is not set
> # CONFIG_BUSMOUSE is not set
> # CONFIG_MS_BUSMOUSE is not set
> CONFIG_PSMOUSE=y
> CONFIG_82C710_MOUSE=y
> # CONFIG_PC110_PAD is not set
>
> #
> # Joysticks
> #
> # CONFIG_JOYSTICK is not set
> # CONFIG_QIC02_TAPE is not set
> # CONFIG_WATCHDOG is not set
> # CONFIG_NVRAM is not set
> # CONFIG_RTC is not set
>
> #
> # Video For Linux
> #
> # CONFIG_VIDEO_DEV is not set
> # CONFIG_DTLK is not set
>
> #
> # Ftape, the floppy tape device driver
> #
> # CONFIG_FTAPE is not set
>
> #
> # Filesystems
> #
> # CONFIG_QUOTA is not set
> CONFIG_AUTOFS_FS=y
> # CONFIG_ADFS_FS is not set
> # CONFIG_AFFS_FS is not set
> # CONFIG_HFS_FS is not set
> # CONFIG_FAT_FS is not set
> # CONFIG_MSDOS_FS is not set
> # CONFIG_UMSDOS_FS is not set
> # CONFIG_VFAT_FS is not set
> CONFIG_ISO9660_FS=y
> # CONFIG_JOLIET is not set
> # CONFIG_MINIX_FS is not set
> # CONFIG_NTFS_FS is not set
> # CONFIG_HPFS_FS is not set
> CONFIG_PROC_FS=y
> CONFIG_DEVPTS_FS=y
> # CONFIG_QNX4FS_FS is not set
> # CONFIG_ROMFS_FS is not set
> CONFIG_EXT2_FS=y
> # CONFIG_SYSV_FS is not set
> # CONFIG_UFS_FS is not set
> # CONFIG_EFS_FS is not set
>
> #
> # Network File Systems
> #
> # CONFIG_CODA_FS is not set
> # CONFIG_NFS_FS is not set
> # CONFIG_NFSD is not set
> # CONFIG_SUNRPC is not set
> # CONFIG_LOCKD is not set
> CONFIG_SMB_FS=m
> # CONFIG_NCP_FS is not set
>
> #
> # Partition Types
> #
> # CONFIG_BSD_DISKLABEL is not set
> # CONFIG_MAC_PARTITION is not set
> # CONFIG_SMD_DISKLABEL is not set
> # CONFIG_SOLARIS_X86_PARTITION is not set
> # CONFIG_UNIXWARE_DISKLABEL is not set
> # CONFIG_NLS is not set
>
> #
> # Console drivers
> #
> CONFIG_VGA_CONSOLE=y
> CONFIG_VIDEO_SELECT=y
> # CONFIG_MDA_CONSOLE is not set
> # CONFIG_FB is not set
>
> #
> # Sound
> #
> # CONFIG_SOUND is not set
>
> #
> # Kernel hacking
> #
> # CONFIG_MAGIC_SYSRQ is not set
>
>
>
>
> Best regards,
>
> Dan Browning
> Network/DB Admin
> Cyclone Computer Systems
>
> -
> To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> the body of a message to majordomo@vger.kernel.org
> Please read the FAQ at http://www.tux.org/lkml/
>

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:45    [W:0.051 / U:4.072 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site