lkml.org 
[lkml]   [2000]   [Nov]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: Some problems with the raid-stuff in 2.4.0-test12pre3
On Thursday November 30, sky@dereference.de wrote:
> Hello people,
>
> I have some trouble with the raid-stuff.
> My machine is a Pentium-III, 256 MB ram and 7 scsi-disks (IBM DNES-318350W
> 17B). I'm using raid5 for 6 of these disks (chunk-size 8).
> Machine boots, I do mkraid /dev/md0 and then mke2fs /dev/md0 and that's
> where the problems start. mkfs tries to write 684 inode-tables and after the
> first 30 it gets very slow. ps ax (with wchan) tells me it hangs in
> wakeup_bdflush.
> I'm rather sure it's related to the raidcode, because without raid the disks
> work as expected.
> I'm using an Adaptec 7892A with the aic7xxx-driver, I have disabled the TCQ
> and the extra checks for the new queueing code, but I have tried with both
> activated, too.
> No related messages from the kernel in the syslog.
> It worked fine with 2.2.x.

Is it just "very slow", but it eventually finishes, it is it so slow,
that it actually stops and doesn't make any progress at all?

raid5 in 2.4 is definately slower than in 2.2. Could that be all that
you are seeing?

NeilBrown
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:51    [from the cache]
©2003-2011 Jasper Spaans