lkml.org 
[lkml]   [2000]   [Nov]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: opl3 under 2.4.0-test10
>On Sat, 11 Nov 2000, Stephen Thomas wrote:
>
>> Mark Hindley wrote:
>> > I am trying to setup my ALS 110 soundcard under my build of kernel
>> > 2.4.0-test10.
>> >
>> > I have built in isapnp support and also the sb and opl3 drivers.
>> >
>> > However, even though I pass opl3=0x388 on the Kernel command line all
>> > I get is an isapnp panic.
>>
>> CONFIG_SOUND_YM3812=y
>>
>> and I'm passing "opl3=0x388" to the driver. However, if I query
>> what synth devices the driver supports, it only reports an
>> AWE32-0.4.4 (RAM512k) sample device. I expect it report an FM synth
>> device, too. I get the same (lack of) effect if I go via the
>> adlib_card code, by saying "adlib=0x388". My investigations so
>> far have shown that when opl3_detect() first tries to get the
>> signature of the OPL3 device, it gets 0xff from the inb() (line
>> 195 of drivers/sound/opl3.c in test11pre1), while the corresponding
>> code in 2.2.18pre19 gets 0x00.
>
>Can you try resetting CONFIG_SOUND_YM3812 to m rather than y. I had a
>similar problem and that is the workaround I came up with. I haven't
>gone back and tried to see why it happened; maybe I need to.

How does this relate to ALS 110? I have tried building the relevant drivers
both as modules and built-in to the kernel. It seems to make no difference.




Mark Hindley

Director of the Music Centre
University of St Andrews

01334 462226/7

http://www.st-andrews.ac.uk/services/music


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:45    [W:0.030 / U:13.256 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site