lkml.org 
[lkml]   [2000]   [Nov]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectproblems with setting non-default modules path in 2.2.14

Hello,

I want to set my development machine so I have multiple
kernels that I can boot. I don't need different versions
of kernel, but only 2.2.14 compiled with different
options (e.g. with/without kdb).

So I have two kernel images, default and debug. I also
compiled modules for both of these kernels and configured
lilo like this:

image = /boot/vmlinuz-pc97-2.2.14-modular
label = linux
root = /dev/hda1
vga = 274
read-only
append = "debug=2 noapic nosmp"

image = /boot/bzImage-debug
label = debug
root = /dev/hda1
read-only
append = "MODPATH=/lib/modules/2.2.14-debug/"

If I boot to debug kernel, 'cat /proc/cmdline' shows this:

BOOT_IMAGE=debug ro root=301 MODPATH=/lib/modules/2.2.14-debug/

but modules are not loaded. Also, I have this in my /etc/modules.conf:

path[usb]=/lib/modules/`uname -r`/`uname -v`
path[usb]=/lib/modules/`uname -r`
path[usb]=/lib/modules/
path[usb]=/lib/modules/default

but this should affect only USB modules, which I don't use.
What am I missing here?

Thanks,

Damir
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:45    [W:0.019 / U:0.408 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site