lkml.org 
[lkml]   [2000]   [Nov]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [BUG] Hard lockup using emu10k1-based sound card
On Mon, 13 Nov 2000, Willis L. Sarka wrote:
> I get a hard lockup when trying to play a mp3 with XMMS;
> Sound Blaster Live card. The first second loops, and I lose all
> connectivity to the machine; I can't ping it, can't to a an Alt-Sysq,
> nothing.

Just for reference, I've been use the ALSA drivers for most of the
2.4.0-testX kernels without any problems (provided you use the driver
version that matches the kernel version). Even under high memory
preasure, swapping, NFS traffic, etc. the worst that happens is sporadic
skipping. XMMS and mpg123 in use. I've tried the kernel emu10k1 a few
times but also got similar lockup's. I haven't tried the kernel emu10k1
since the NMI watchdog was added. This should show something? ... but
I guess you can't see anything because you're in X. I wonder if you'd see
anything if you were using mpg123 and working on the console?

My system:
RedHat 7.0
kernel 2.4.0-test11pre3 SMP (soundcore as modules)
ALSA drivers 0.5.9d
Gigabyte 440BX SMP (Dual Pentium II 450), 256MB,
Intel Ethernet Pro 100, Adaptec AIC-7895 Ultra SCSI

--
Hans Grobler <grobh@sun.ac.za>
Department Electronic & Electrical Engineering
University of Stellenbosch, South Africa

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:45    [W:0.048 / U:6.904 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site